Register File Geodatabase with ArcGIS Server and Editing Feature Classes

2914
4
08-05-2013 12:29 PM
MichaelVolz
Esteemed Contributor
To All ArcGIS Server 10.1 Users:

I have a file geodatabase that I have registered with ArcGIS Server so the file geodatabase does not get copied locally to the ArcGIS Server (AGS) server.  I want to update the feature class, but I am getting access denied error messages.  I made sure all mapservices hitting the file geodatabase are stopped, but I still get access denied error messages.  I then copied the file geodatabase to the C-drive of the AGS server, where I was able to edit the feature class.  I then tried to copy the updated feature class back to the file geodatabase that was the datasource for a mapservice, but I still received an access denied error.

Has anyone encountered this issue, so they would know what the problem is?

I did not think that registering a file geodatabase would put locks on the file geodatabase, only mapservices that are started would put locks on the file geodatabase feature class.

Any help or hints are greatly appreciated.
Tags (2)
0 Kudos
4 Replies
StevenMoore1
Occasional Contributor II
Hi,

Even though the map services are stopped, there may still be lingering .lock files in the geodatabase. You can open the file geodatabase folder in Windows Explorer and see them. If there are any there, you can manually delete them.

Also, you could try disabling schema locking by unchecking the 'Lock Database Schema' checkbox under the 'Parameters' tab for the service in Server Manager.

Hope this helps.
0 Kudos
MichaelVolz
Esteemed Contributor
Steve:

If I do not find any lock files in Windows Explorer for the file geodatabase, does that mean that the schema locks are not the issue preventing me from editing the file geodatabase feature class?
0 Kudos
StevenMoore1
Occasional Contributor II
Hi,

If you're not seeing any .lock files in the gdb then I don't see how a lock could be preventing editing. Have you tried restarting ArcGIS Server?
0 Kudos
MichaelVolz
Esteemed Contributor
Steve:

It turns out it was a permissions issue.  The NTFS level permissions needed to be modified which solved the problem.
0 Kudos