Register data store error - Machine: <machine name> [<databasename>: (null)]

10288
12
Jump to solution
04-12-2015 07:51 PM
TimothyHales
Esri Notable Contributor

I am getting the following error when trying to register my database with my server.

Machine: <machine name> [<databasename>: (null)]

ArcGIS 10.3

SQL Server 2012

Database authentication

1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

Hi Timothy,

First, close all applications and restart ArcGIS Server Service.

I hope an SDE user has been created for the database you want to register ( Create Enterprise Geodatabase ). Connect to the database from ArcCatalog using the SDE user.

Once connected successfully, right-click the geodatabase > Properties.

Copy the .sde path and use this path to register the database in ArcGIS Server Manager.

Thanks,

Jay



Think Location

View solution in original post

12 Replies
JayantaPoddar
MVP Esteemed Contributor

Hi Timothy,

First, close all applications and restart ArcGIS Server Service.

I hope an SDE user has been created for the database you want to register ( Create Enterprise Geodatabase ). Connect to the database from ArcCatalog using the SDE user.

Once connected successfully, right-click the geodatabase > Properties.

Copy the .sde path and use this path to register the database in ArcGIS Server Manager.

Thanks,

Jay



Think Location

View solution in original post

TimothyHales
Esri Notable Contributor

That worked for getting my database registered. Thanks!

0 Kudos
JimenaMartinez
New Contributor

I have the same error

Machine: <machine name> [<databasename>: (null)]

But this solution didn't work for me. Any other ideas?

Thanks,

0 Kudos
DarwinQuispe
New Contributor II

Hello,

In my case, the solution to this problem was install database client (PostgreSQL) in my ArcGis Server machine and in my ArcMap Machine

AntonioSan_José
New Contributor III

I have the same problem and the solution neither works for me. PostgreSQL is installed in both machines and still doesn't work.

Any solution?

Regards.

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

Please provide more info:

1. Where are you trying to Register the database with server: In ArcCatalog or from Server Manager..?

2. Which version of ArcGIS and PostgreSQL are you working with?

3. Is this a new installation and are you trying for the first time to register a database with server on this?

0 Kudos
AntonioSan_José
New Contributor III

1. Where are you trying to Register the database with server: In ArcCatalog or from Server Manager..?

From ArcCatalog

2. Which version of ArcGIS and PostgreSQL are you working with?

ArcGIS 10.2

PostgreSQL 9.6.1 in local

PostgreSQL 9.3.15 in server 

3. Is this a new installation and are you trying for the first time to register a database with server on this?

Yes

I am going to update the version of PostgreSQL to 9.6.1 in the server and try again.

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

These are the PostgreSQL versions supported at 10.2.x:

Supported database versions

PostgreSQL 9.0.5 (64-bit)

PostgreSQL 9.1.3 (64-bit)

PostgreSQL 9.2.2 (64-bit)

System Requirements 

PostgreSQL 9.6.x is not even supported at ArcGIS 10.5: PostgreSQL database requirements for ArcGIS 10.5—System Requirements | ArcGIS Desktop 

Install a supported version of PostgreSQL database and try again.

AntonioSan_José
New Contributor III

Ok, I'll try version 9.2.2.

Thank you for your quick response.

Regards!

0 Kudos