Python Error "Object: Tool or Environment <Tool> not found

09-08-2021 06:57 AM
Occasional Contributor III

I have a scrip that was generated in ArcCatalog (published from a model) , that I run using IDLE 2.7.18

# Import arcpy module
import arcpy
from arcpy import env
import arcgisscripting

arcpy.env.overwriteOutput = True

No other toolboxes called or anything, just location strings and variables after the above^

This script has worked many times before, both on my own PC and once it is copied onto a server machine running Server for ArcGIS 10.8.1. Today I attempted to run the script on the server machine and get the error:

Start Parcel Update
...ERROR! Sending email back to (my email)
Line 49
Object: Tool or environment <Delete_management> not found

Delete Management comes from arcpy, which is specifically called and does exist in the correct program files location (never been moved). I was able to successfully run the script on my own machine. As far as I know, there haven't been any changes made to licensing or anything since the last time I ran it either, so I'm kind of stumped. This seems to be occurring with other scripts run from the Server as well. A separate scrip is throwing the "not found" error when trying to run GenerateAttachmentMatchTable_management from in arcpy.

I'm far from proficient at python and scripting, so any help or thoughts would be greatly appreciated.

0 Kudos
1 Reply
New Contributor

I am also having trouble running a tool, but in 10.8.2.

0 Kudos