Problem with Arcgis Enterprise 10.6.1 after applying Enterprise Sites 2 Patch

11-25-2019 06:30 AM
New Contributor II


Last Friday we installed Enterprise Sites 2 Patch on our 10.6.1 ArcGIS Enterprise instance and now it seems to be broken.

We have Portal and Server federated and Data Store. All software are installed in the same server machine on our network.

We use two different Web Adaptor one for Server (named: server ) and one for Portal (named: portal).

The patches  we have already installed are:

Our server is exposed both on intranet and in public network with two different addresses and on the same machine there's the Internet Information Services (IIS). 

At a first look the problem may be with the WEB Adaptor of Portal, when I call my portal address with my web adaptor (https://MachineName/portal/home) the browser is automatically redirect to https://MachineName:7443/arcgis/home accessed without web adaptor.

When I try to reach form outside my Server (https://MachineName/portal/home) I successfully do, but when I try to login the browser send me back:

Unable to load https://MachineName/portal/sharing/rest/portals/self?f=json status: 0

And I'm not able to insert my credentials.

I'm able, instead to reach both admin interfaces of Portal and Server with  webadaptor addresses.

The security configuration of the Server are:

Authentication tier:ARCGIS_PORTAL+
Authentication mode:ARCGIS_PORTAL_TOKEN

When I look at webadaptor configuration in the HOST machine all seems to be OK

I also try to reconfigure the web adaptor but with no success.

Before the patch installation all seemed to be right ...

I must say, Honestly, that in the last week our IT made same changes in the network configuration (Proxy and Firewall), and probabilly from these changes we had not restart yet the portal and server services.

Before disinstall the patch or re-install webadaptor or review the federation, I ask for some helps.



0 Kudos
5 Replies
Occasional Contributor II

Hi Pierpaolo,

You mentioned a proxy server. Is this a forward or reverse proxy?

If using a reverse proxy server, I would recommend checking with your IT department to make sure that the reverse proxy is properly configured to match the web adaptor name. For example, in the httpd.conf file, the ProxyPass and ProxyPassReverse directives need to include the web adaptor name. An example:

ProxyPass /arcgis
ProxyPassReverse /arcgis

Also, is the X-Forwarded-Host header properly set?

Lastly, check in the Portal Admin directory to ensure the WebContextURL property is set. Sign in to the Portaladmin directory as an administrator, then navigate to System > Properties > Update. 

Make sure the WebContextURL is properly pointing to the reverse proxy server (see screenshot below).

Hope this helps!

- Rachel

For further reference:

Configure your portal to use a reverse proxy server—Portal for ArcGIS (10.7 and 10.7.1) | ArcGIS Ent... 

Configure a reverse proxy server with ArcGIS Server—Deploy | ArcGIS Enterprise 

Single-machine deployment with reverse proxy server—ArcGIS Web Adaptor (IIS) Installation Guide | Ar... 

0 Kudos
New Contributor II

Thanks Rachel

I'll check with my IT the changes in the Network config.

In the Portaladmin in  System > Properties > Update

I see:


0 Kudos
New Contributor II


I spoke with the IT and they told me that in the server machine there aren't proxy, but they made some address mapping in the configuration etc\hosts file.

when I applied the patch, Portal was restart and so the new configuration probably created the problem.

I found a precedent thread in which a similar problem was caused by the etc\hosts file.

As suggested in the thread I commented the new mapping in the file and restarted portal service, after the restarted I uncommented back the file. 

The problem with the redirect was solved, but I have now another problem:

In the Portal home page I don't see any of the content item.

I see correctly Groups and Users but not Maps, Layers, Apps and other contents.

But If I browse to the correct URL of any ITEM I can fetch, and also the items are visible in ArcGIS PRO and if I search with Python API!

I tried to reindex the portal but nothing has changed!

After the Portal restart I had another issue with AD domain Users  access, but I solved with the updating (without changing any parameter!) of the identity store in the portaladmin,

Any ideas about this problem?



0 Kudos
Esri Notable Contributor

Portal doesn't handle machine name changes too well, so that's likely causing at least the first problems. What does the index status show? You may need to rebuild the search index manually.

0 Kudos
New Contributor II

Thanks Jonathan for your reply

The index status seems to be good:

Index Status {.../portaladmin/system/indexer/status}

TypeCount in storeCount in index

I've just noticed that in the Portal Web interface:

  • Organization's Users are 28 (not 71)
  • Groups in Organization are 12 (not 379)

But if I count the records in the gw_users table in Postgresql DB the result is 72, and in gw_items are 9545 ...

I've, any way, made a FULL Reindex and also made a content configuration update (.../portaladmin/system/content/configuration/update), but nothing has changed.

I've checked also .../portaladmin/system/directories and the folder paths in the server machine seem to be correct.

This is the CONTENT directory path:

Path: {"type":"fileStore","provider":"FileSystem","connectionString":"E:\\arcgisportal\\content"}

In this directory I find, in items folder, my content.

In Portal's logs I don't find nothing can help to understand!!

0 Kudos