Problem starting PublishingTools Service

16728
40
Jump to solution
01-11-2018 01:18 AM
Syed_AzamGhouri
New Contributor III

I am using ArcGIS server 10.2.2. The following message appeared when starting PublishingTools service and it is persistent. Is there a fix for this. Please help. Thanks

Service failed to start

System.PublishingTools.GPServer: 
XXXXXXXXXXXXXXXXXX
Service containing process crashed for 'System/PublishingTools.GPServer'.Please see if an error report was generated in 'C:\arcgisserver\logs\SWPRUPFS.MMAA.GOV.QA\errorreports'. To send an error report to Esri, compose an e-mail to ArcGISErrorReport@esri.com and attach the error report file.

1 Solution

Accepted Solutions
RandallWilliams
Esri Regular Contributor

Esri has released patches for ArcGIS 10.5.1, 10.4.1, and 10.3.1.

https://support.esri.com/en/download/7576

View solution in original post

40 Replies
JayantaPoddar
MVP Esteemed Contributor

Please provide full control the ArcGIS Server account and the Current User account have for ArcGIS Directory and ConfigStore. Then restart ArcGIS Server service (Run > services.msc)



Think Location
Syed_AzamGhouri
New Contributor III

Thanks a lot dear Jayanta. What are these accounts and the directories on the default installation of ArcGIS server? Just to speed up fix. Thanks in advance.

0 Kudos
Syed_AzamGhouri
New Contributor III

Did but problem remains.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Could you follow these steps

1)stop arcgis server services.

2)delete the lock files(*.glock and *.rlock ) in arcgisserver\config-store.

3) restart arcgis server service.

4)stop the pending stopping service and then start it.



Think Location
0 Kudos
Syed_AzamGhouri
New Contributor III

There's a locks directory in it. I deleted all its content and started the Arcgis server service. Still problem remains. There is no rlock file found. Thanks for your help Jayanta. 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Then try sending the error report file to ArcGISErrorReport@esri.com

They should get in touch with you soon.

And while you wait, you could reboot the ArcGIS Server machine, if possible.



Think Location
0 Kudos
Syed_AzamGhouri
New Contributor III

I did that as well a couple of days ago. No response yet. Thanks for your time.

Syed_AzamGhouri
New Contributor III

Dear Jayanta if I do a fresh installation of ArcGIS server do I need to recreate all services? We have flex and javascript apps that consume the services. Thanks in advance. Also will it solve the issue?

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

I will advice you to consult with Esri Tech Support before reinstalling ArcGIS Server. 

https://support.esri.com/en/contact-tech-support 



Think Location
0 Kudos