Is there a maximum size limit of Vector Tile Package when publishing a hosted Tile Layer?

1354
4
06-13-2018 04:20 AM
RobertJones11
New Contributor II

I have generated a Vector Tile Package (.vtpk) which is slightly over 36Gb. I used the Share Package GP tool in Pro to upload it to Enterprise, and it uploaded successfully, which I verified by downloading the vtpk, and viewing it in Pro.

I then attempted to publish the VTP as a hosted Tile Layer by accessing its page in Enterprise, and clicking Publish. After an hour or two the process failed, reporting an error in the browser and the following in the logs, which seems to be related:

SEVERE     
The containing process for 'System/PublishingTools' job 'j3297956af3dd42ce9b0113fd010168ff' has crashed.
    2018-06-13T11:25:04     Server     DESKTOP-xxxxxxx         7553         17032     46     
SEVERE     
Processing request took longer than the usage timeout for service 'System/PublishingTools.GPServer'. Server request timed out. Check that the usage timeout is appropriately configured for such requests.
    2018-06-13T11:24:54     Server     DESKTOP-xxxxxxx         7549         17032     46

And so to my questions: firstly, is there a known limit on the maximum size of VTP that can be published as a hosted Tile Layer, or is this limit currently unknown?

Secondly, if my 36Gb vtpk is within the limit i.e. it should be possible to publish it, are there any settings I might be able to tweak to overcome the error? I have tried upping some values in the PublishingTools GP service, but any outside insight would be most appreciated.

0 Kudos
4 Replies
RobertJones11
New Contributor II

I should have mentioned I am running 10.6

0 Kudos
RobertJones11
New Contributor II

Same result with a 29Gb vtpk. Got the following in the log:

SEVERE
The containing process for 'System/PublishingTools' job 'j02b371c415b64171bd5fdf6b19fff79b' has crashed.
0 Kudos
RobertJones11
New Contributor II

I've raised this as a support case.

In case it might help someone else, I have managed to hack around this problem by publishing effectively a skeleton service containing a vtpk based on a map containing only a single layer, and then swapping in the folders from the full size vtpk into the published service's folder, which will be located somewhere like:

D:\arcgis\arcgisserver\directories\arcgiscache\VectorCache\Hosted\sizetest\VectorTileServer

So for clarity the steps are:

1. Generate a tiny vtpk e.g. remove everything but simplest layer from your map document

2. Run Share Package to upload to Portal

3. Go to Content and click on item created in step 2. to access item's page

4. Click Publish and wait for service to publish

5. Go to published service's folder e.g. D:\arcgis\arcgisserver\directories\arcgiscache\VectorCache\Hosted\sizetest\VectorTileServer

6. Delete everything in that folder

7. Unzip your full size vtpk and copy the following into folder above:

folders:

 resources

tile

tilemap

 

file:

 root.json

8. Go back to the item in Portal and view in Map Viewer - it should be working with the new data

0 Kudos
GarimaTiwari
Esri Contributor

This issue has been addressed at 10.6.1. 

The recommended workaround for this issue is listed below: 

1. Go to Server Manager and update publishing tool gp service usage time out to "360000" (more than 2 hours)

2. Restart ArcGIS Server.

3. use Share Package tool to upload and publish the VTPK

is there a known limit on the maximum size of VTP that can be published as a hosted Tile Layer, or is this limit currently unknown?

No, there is no limit to the size of VTPK. 

The publishing tools that extracts the content of VTPK in ArcGIS Enterprise has a usage timeout of 2hours. When the usage timeout was being update to 3-4 hours the Service was not honouring the updated usage timeout. A restart of ArcGIS Server after increasing the usage timeout resolves this bug. 

0 Kudos