Installing Web Adaptor 10.8.1

751
2
02-01-2022 03:09 PM
forestknutsen1
MVP Regular Contributor

We are upgrading Enterprise from 10.7.1 to 10.8.1. Our Portal environment uses portal tier authentication. When I installed web adaptor for portal I got this when trying to configure it:

"Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists). Ask the Web server's administrator to give you access to 'C:\inetpub\wwwroot\portal\webadaptor\WebAdaptor.aspx'."

forestknutsen1_0-1643756579345.png

After some pain I found that granting full access to IUSR the web adaptor folder fixed the issue.

 https://stackoverflow.com/questions/10418669/hosting-asp-net-in-iis7-gives-access-is-denied

Is the IUSR supposed to have full access to the web adaptor folders with portal tier authentication?

 

Tags (3)
0 Kudos
2 Replies
ReeseFacendini
Esri Regular Contributor

When configuring web adaptors (or any ArcGIS Enterprise component), it's best to use a more current browser than Internet Explorer (Chrome, Firefox, Edge).  IE can present odd behavior, and is not a supported browser starting at 10.8.  It serves a functional purpose within Windows, but not for Esri software.

No it's not necessary to grant the IUSR account full permissions to the web adaptor folder, the default of 'Read & Execute', 'List folder contents', 'Read' are all that are required

RichAnderson
New Contributor

I just ran into this same error on one of my two web adaptor servers when upgrading from 10.8.1 to 10.9.1.  I ended up comparing the permissions on both and found that the local group <servername>\Users was missing on the server with the error on the wwwroot folder.  Once that group was added with the default read & execute, list folder contents and read pemissions, the error was resolved.

0 Kudos