Select to view content in your preferred language

Importing CA certificate failed

1803
3
Jump to solution
01-17-2023 12:55 PM
BillShoop
New Contributor II

Hello all!

I am trying to import an existing server certificate (.pfx) but keep getting "Importing CA certificate failed." message. I dig into the logs and it says the password is incorrect. Weird because I was able to import the .pfx into IIS and bind it to port 443 with the same password. Why would I be getting a password error?

SSLCert.PNG

ArcGIS Server 10.9.1

Thanks!

0 Kudos
1 Solution

Accepted Solutions
JeffSmith
Esri Contributor

The behavior you are describing sounds like an issue related to special characters in the .pfx password that are getting misinterpreted by ArcGIS Server. That being said, a bug was logged several years ago for that issue specifically which was fixed in 10.7.

BUG-000107534 - SSL Certificates with special characters in the password fails to import to ArcGIS Server.

At 10.9.1 I wouldn't think you would run into that issue.  If it is a password issue, a possible workaround would be to import the pfx into IIS (since that works) and export it to a new pfx with a different password.

View solution in original post

3 Replies
JeffSmith
Esri Contributor

The behavior you are describing sounds like an issue related to special characters in the .pfx password that are getting misinterpreted by ArcGIS Server. That being said, a bug was logged several years ago for that issue specifically which was fixed in 10.7.

BUG-000107534 - SSL Certificates with special characters in the password fails to import to ArcGIS Server.

At 10.9.1 I wouldn't think you would run into that issue.  If it is a password issue, a possible workaround would be to import the pfx into IIS (since that works) and export it to a new pfx with a different password.

BillShoop
New Contributor II

Hey @JeffSmith , I was aware of the bug but like you I wouldn't think it would effect it. Looks like we are both wrong haha. After changing the cert's password to remove the special characters, I was able to import the cert into the ArcGIS Server admin API.

Thanks!

SimonSchütte_ct
Occasional Contributor III

@JeffSmith I did encounter this issue in ArcGIS Server 10.9.1. The Special Characters used were $ and ~. After changing the password to not include any special characters ( alphanumeric only), the import worked.

There is also an Enhancement logged: ENH-000148002: Enable using special characters (like €, ₹) in the SSL Certificate's password while importing the certificate to ArcGIS Server

btw: Spaces in the file name of certificates can also be problematic.

0 Kudos