Import layer from portal as geofence in GeoEvent

104
2
Jump to solution
07-18-2022 01:09 AM
ElviraForslund
New Contributor II

My goal is to have a geofence in the portal (as a layer) , that can be edited with the editor widget from ArcGIS API, that at the same time can be imported as a geofence in GeoEvent to work as a real time geotrigger. 

So far I have published a feature layer from ArcGIS Pro to my Enterprise portal that contains a Polygon layer. I wish to import this feature/polygon layer as a geofence in GeoEvent. However, when selecting the feature layer as Service in GeoEvent, the polygon layer cannot be selected as the Layer for the GeoFence and I fail to import this. 

Is there a way to make this work? I have not found a way to import anything from the portal as a geofence in GeoEvent. How do I import a geofence to GeoEvent?

Thank you in advance for any help or suggestions. 

0 Kudos
1 Solution

Accepted Solutions
ElviraForslund
New Contributor II

Hi @MCameron and thank you for your reply.

I did managed to resolve the issue I had with importing GeoFences through the following post : GeoEvent: Failure to Import or Synchronize GeoFenc... - Esri Community . 

After this, everything worked as it should! 

I apologize for the late reply, but thank you once again for the help! 

View solution in original post

0 Kudos
2 Replies
MCameron
Esri Contributor

Hi @ElviraForslund 

It would be good to gather some additional information, could I ask you to please share with me:

  • Is GeoEvent server installed on the same server machine as the ArcGIS Enterprise server? 
  • Are you recieving any error messages when trying to import the layer as a geofence? 
  • Could you share a screenshot of what you are seeing when trying to import a geofence? 
  • Has this process worked previously, and has now stopped working? 

 

Hopefully, with a little more info we will be able to offer some advice

Martine

0 Kudos
ElviraForslund
New Contributor II

Hi @MCameron and thank you for your reply.

I did managed to resolve the issue I had with importing GeoFences through the following post : GeoEvent: Failure to Import or Synchronize GeoFenc... - Esri Community . 

After this, everything worked as it should! 

I apologize for the late reply, but thank you once again for the help! 

0 Kudos