IIS Web Adaptor 10.1SP1 error

12-12-2012 09:59 AM
Occasional Contributor III
I'm trying to install Server 10.1 SP1 and the IIS Web Adaptor on a Win2008R2 box, completely clean machine, no previous verions of any Esri Products.

I got Server to install fine, and can open Manager, browse the rest/services folder, etc..

I installed the Web Adaptor SP1 and that's where the trouble begins.

After installation, it will automatically try to open http://localhost/arcgis/webadaptor which returns a 404 not found error
If I change localhost to either the IP or server name I get the WebAdaptor screen.  I enter the server name:6080 for the URL and the Primary Site Admin name/pwd and hit configure and I get an error saying 'Could not find any recognizable digits' and that's it.

Anyone seen this & have any suggestions?

Thanks, Terry
0 Kudos
11 Replies
Occasional Contributor III
for whatever its worth, on my configuration page, i specify my fully qualified domain name for the GIS Server URL. Ex:

0 Kudos
Occasional Contributor III
Thanks for the suggestion, that didn't help either.  I uninstalled the Web Adaptor and tried to reinstall, but am now getting an error about duplicate values in a listbox, as shown in the attached screenshot.  Tech Support, here I come..
0 Kudos
Occasional Contributor III
Hmm, makes me think that there's still a reference down in c:\inetpub\wwwroot (or rather a folder still named after your web adaptor).

Uninstalling a web application doesn't always remove folders there.

Edit: Terry, did a little digging for you and have a look here

0 Kudos
Occasional Contributor III
Hi Zachary,

I had deleted the previous 'arcgis' folder and Virtual Dir in IIS - you get a warning saying it already exists when trying to run the WA install.

I'd seem similar posts regarding using the command line to install if there are multiple web sites.  Tried that and still failed (plus yesterday I only had 1 site in IIS).  I was able to fix that 2878 error ....  issue was due to the bindings in the website - there were 2 entries pointing to port 80.  I removed the duplicate entry from the bindings, restart the website and off the races with the WA install.

Still cannot get the WA to configure though.  After it installs when I go to <server>/arcgis/webadaptor and enter the server:6080 (or FQDN), Site Admin user & pwd I get this error -
"Additional non-parsable characters are at the end of the string"
If I change the pwd to be only alpha-numeric (got the idea from a known bug involving SSL and pwd with special chars), I get a different error -
"Could not find any recognizable digits"

Waiting on Tech Support for next wall to bang head on.  Ugh.
0 Kudos
Occasional Contributor III
After spending most of yesterday fighting with this, including over an hour of screen sharing w/ Esri Tech Support, I got past the mysterious 'Could not find any recognizable digits' error.  In another post here in the Installation forum someone mentioned they were getting the same error in IE but get the WA to configure using Chrome.  I started messing with IE settings & eventually got it to work - I added the server to the 'Local Intranet' zone in IE's security settings. 

Hope this can help someone else from hours of frustration..


also, found this was getting logged in the WA's folder under wwwroot (log.txt) -

Log Entry : 12/14/2012 7:38:42 AM
  Request failed
  :Could not find any recognizable digits.
  :   at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
   at System.Convert.ToByte(String value, Int32 fromBase)
   at ESRI.ArcGIS.WebAdaptor.Utility.HexStrToBytes(String hex)
   at ESRI.ArcGIS.WebAdaptor.Config.Configure(Object sender, EventArgs e)
Occasional Contributor III

Thanks Teri this really helped us. We had the same issue. IT had Internet Explorers security setting on high and we couldn't add the server (it was in the DMZ) to the trusted zone. But we ran the setup in Firefox and it worked fine.

Occasional Contributor III

That worked! Thank you!!

0 Kudos
New Contributor II

Adding the site to my Local Intranet zone worked for me.  Thanks!

0 Kudos
Frequent Contributor
Any of the languages, e.g. .NET or Java, which compile to byte codes can be examined in source code form.  For .NET, I use Reflector although there are other free tools for doing so.  Java also has many such tools.

If you look at the code inside the web adaptor, the logic is failing while trying to decrypt a password.

I don't know why it is failing but I have seen other posts indicating that using special characters within the password breaks ArcGIS Server.  If your password has special characters then you might consider removing them.
0 Kudos