How do I hide port 6080 in ArcGIS server mapped URL

2857
6
02-25-2016 04:44 PM
VincentOchiel
New Contributor

To externalize our arcgis web map services we mapped our ArcGIS 10.3 server as follows:  gisserver1 to mapping.domain.com   however the issue at hand  is that http://mapping.domain.com/arcgis/rest/services/ does not work and generates a 404 file not found

and only works as http://mapping.domain.com:6080/arcgis/rest/services/  (I can see my map services) and also still works as http://gisserver1:6080/arcgis/rest/services/

The ArcGIS web adaptor has been installed and gisserver1 configured with the web adaptor, so my expectation was that the 6080 would be hidden.

I'm not sure how I can get rid of the 6080 in the mapped URL. Anything I can check and tick off on would be a great HELP!!

6 Replies
StevenGraf1
Regular Contributor

If you install the ArcGIS Web Adaptor you no longer need to use the port number.

About the ArcGIS Web Adaptor—Installation Guides (10.4) | ArcGIS for Server

-Steven

0 Kudos
AbhishekRathi1
Occasional Contributor

Dear Vincent,

Kindly go through following procedure to get the desired output.

If you've configured the ArcGIS Web Adaptor with ArcGIS Server and have not enabled administrative access, the only way you can administer your site is by connecting directly through port 6080, for example,http://gisserver.domain.com:6080/arcgis/manager. However, if ArcGIS Server is using web-tier authentication, you can configure your site to disable users in the identity store from administering the site through port 6080. In this manner, users are forced to access your site through the Web Adaptor URL, for example,http://webadaptor.domain.com/arcgis/manager.

In order to disable administrative access on port 6080, ArcGIS Server must be configured to use web-tier authentication and at least one user in the identity store must have administrative access to the site. Additionally, the web server hosting the Web Adaptor must enforce user authentication using the same identity store configured with ArcGIS Server. To learn more, see Configuring ArcGIS Server security.

The primary site administrator account will still be able to administer the site through port 6080. To fully disable access on port 6080, you can optionally disable the primary site administrator. Keep in mind that if the Web Adaptor becomes unavailable or if the web server is unable to authenticate users that have administrative access, you will be unable to administer your site. To recover from this state, you'll need to re-enable the account using the password reset utility. Once the account is re-enabled, connect to the site through port 6080 with the account.

To disable administrative access to ArcGIS Server on port 6080, follow the steps below:

  1. Configure the Web Adaptor to allow administrative access to your site. For full instructions, see Configuring the Web Adaptor after installation.
  2. Open the ArcGIS Server Administrator Directory using the Web Adaptor URL and log in with a user that has administrative permissions to your site. The Administrator Directory is typically available athttp://webadaptor.domain.com/arcgis/admin.
  3. Click security > config > update.
  4. On the Operation - update page, disable the Allow direct administrator access option and click Update.
  5. Optionally, disable the primary site administrator account to fully disable access on port 6080. To do so, see Disabling the primary site administrator.

After completing these steps, you should ensure that all of your server connections in ArcGIS for Desktop and client applications are connecting ArcGIS Server using the Web Adaptor URL.

AbhishekRathi1
Occasional Contributor

Kindly go through the below link to setup Web Adaptor properly.

Configure ArcGIS Web Adaptor after installation—Installation Guides (10.4) | ArcGIS for Server 

VincentOchiel
New Contributor

thanks Abhishek for your helpful pointers!

Should my DNS look up from http//maps.mydomain.com be to a machine that the web adaptor is installed on?  At the moment, I've got the webadaptor installed on it's own server and my DNS look up is to another machine where my web services reside (no web adaptor installed on the web services machine). The web services server is configured with my web adaptor.

0 Kudos
RichardsonAluvilayil2
New Contributor III

Hello Vincent,

From your initial query I understand that you have installed Server on gisserver1 and Web Adaptor on mapping and configured your ArcGIS Server with the Web Adaptor.

First, you have to make sure that you are able to access the Server rest end point from the Web Adaptor machine like this: http://mapping.domain.com/arcgis/rest/services

Once this is done, you will have to bind/nat the External/Public domain IP to your Web Server IP. Contact your Network or IT team for this configuration.

Hope this helps. Thanks,

Richardson

SebastienPetit
Occasional Contributor

You can also simply configure your reeverse proxy.

ie test.discomap.eea.europa.eu is going to port 6080 but you dont see it