How can you fix a corrupt ArcGIS Server lifecycleinfos.json file

12-02-2019 10:47 AM
New Contributor III

This question relates to an ArcGIS Server 10.7.1 implementation. 

When trying the start a service, the following error occurs:

I have discovered ten services that have corrupted lifecycleinfos.json file. The file is full of unreadable characters.  I'm assuming this is the problem, because all other json files associated with the services are readable and have '{' as the first character in the file. 

A typical lifecycleinfos file will look something like this:


I've tried to republish the services, but they can't be republished.  There is an "ERROR 001369: Failed to create the service" error.   I've also tried to stop or delete the services in the Server Manager, but they can't be deleted for a similar error Failed to stop one or more services: A JSONObject text must begin with '{' at character 1 of.

Here is the file location for lifecycleinfos.json i  arcgisserver -> config-store -> services -> service folder -> service.MapServer -> esriinfo

There is a lifecycleinfos.json.rlock file as well.  

Is there a way to repair the lifecycleinfos.json file? 


0 Kudos
2 Replies
Esri Notable Contributor

Not sure how the JSON could have gotten corrupted. What's the timestamp on the file? Does it correspond to anything happening on the machine, (machine was disconnected from power, etc). Somewhat of a hacky workaround is to simply replace the contents with valid contents from a different service. It just needs valid JSON.

Occasional Contributor

Hi...i have just had this problem with a single service which couldn't be started or deleted and only gave the following error message - "A JSONObject text must begin with '{' at character 1 of"

After reading the threads I decided to delete the lifecycleinfos.json file (which by the way was only filled with NULLNULLNULL) and also all of the lockfiles. Afterwards I was able to delete and republish the serice.


Hope this helps someone.



0 Kudos