Hosted Feature Services running at different versions

303
2
05-20-2019 02:05 PM
Joshua-Young
Occasional Contributor III

I have been trying to figure out why after upgrading from ArcGIS Enterprise 10.6 to 10.6.1 all my hosted feature services published before the upgrade are treated like regular feature services in ArcGIS Portal but are still treated like hosted feature services in ArcGIS Server Manager. All hosted feature services published after the upgrade are operating as expected.

I did some comparisons of the JSON of hosted services before the upgrade and hosted services after the upgrade. The formatting of the JSON is very different between the services before and the services after. I have even found hosted services with the "currentversion" value listed as 10.31, 10.5, 10.51, 10.6, and 10.61. I do not know how we have hosted feature services at version 10.31 since we did not start using ArcGIS Portal until 10.5, but our ArcGIS Server was originally at 10.31. My guess it that ArcGIS Portal 10.6 and older could understand the JSON format of the older hosted feature services but ArcGIS Portal 10.6.1 cannot. The config-store for ArcGIS Server has the currentVersion listed as 10.61. I have always had trouble getting the "Complete Upgrade" part of the ArcGIS Server upgrade process to either run at all or run correctly on our server. 

Does anyone know how to manually force ArcGIS Enterprise to upgrade a hosted feature service's JSON to the current version?

0 Kudos
2 Replies
MichaelSchoelen
Occasional Contributor III

For the Continue Server Upgrade, have you seen this post on that issue? 

Check the version of the config-store by going to C:\arcgisserver\config-store\version.json (or wherever the config-store is located). If it is not 10.6.1, use this workflow to get back to the "continue server upgrade" screen:

1. Stop AGS service (in my case, on both machines in my HA site).

2. Rename the C:\Program Files\ArcGIS\Server\framework\etc\config-store-connection.xml to config-store-connection-upgrade.xml (in an HA site this only needs to be done on the machine you then use to access Manager in step 4.)

3. Start AGS service (in my case, on both machines in my HA site).

4. Go to https://localhost:6443/arcgis/manager and you should be prompted to continue server upgrade.

As for the services having an outdated version number, have you tried editing them and seeing if that updates the value in the service metadata? Maybe change something small in the server manager?

0 Kudos
Joshua-Young
Occasional Contributor III

Yes, I performed those steps when going from 10.6 to 10.6.1 because I first had to do that when we went from 10.5.1 to 10.6 to get the Continue Server Upgrade to show up. We had issues with the Continue Server Upgrade and had to call Esri Support afterwards to fix several issues. ArcGIS Server Manager and the config-store json file have the version as 10.6.1 now.

The only remaining issue that I have noticed is with hosted feature services published before the upgrade. ArcGIS Portal thinks they are regular feature services and ArcGIS Server thinks they are hosted feature services. So neither interface will allow me to modify those services' settings. In comparing the JSON of the old hosted feature services to new hosted feature services I noticed that the JSON schema is very between them and the old hosted feature services have old version numbers.

0 Kudos