Error while starting AppServer. Required port '4000' already in use.

12109
11
03-04-2013 01:48 PM
New Contributor
Hi,
I tried to install 3 time Arcgis server on Amazon EC2. I have used the AMI : Esri ArcGIS 10.1 SP1 for Server on Ubuntu with Postgresql (Oct 2012)(ami-31b1260b). I tried with the N. Virginia site and Sydney site and I have exactly the same problem. I have these 2 warning on the server all the time.

- WARNING:The App Server was found to be stopped when it should have been started. Restarting it.
- SEVERE:Failed to start the server machine 'LOCALHOST'. Failed to start the server machine 'LOCALHOST'. Error while starting AppServer. Required port '4000' already in use.


I have stopped and started Arcgis server, I have rebooted the instance but the problem persist.
I have the same problem if I access to the server via the manager, the Arcgis server admi directory or arcgis Desktop.

Currently, there are nothing else than the SampleWorldCities map Service and the default geoprocessing/geometry services on the server.I am using the AWS free usge tier (t1.micro instance type). Is that the problem?
Reply
0 Kudos
11 Replies
New Contributor II
Same issue with our server running on a VMWare VM (not EC2). Any solutions?

Runs for awhile, crashes, and eventually restarts. Logs show problem with port 4,000 already in use.

Eric
Reply
0 Kudos
New Contributor II
I was getting the same error on a Linux server, after a not so graceful shutdown of ArcGIS Server, I ended up finding a processes " C:\windows\system32\explorer.exe /desktop" which looked odd to me, i kill it, and restarted ArcGIS Server and everything came back up.  The " C:\windows\system32\explorer.exe /desktop" process came back up too, this is clearly launched by ArcGIS Server.

hope this helps someone in the future.

-Andy
Reply
0 Kudos
New Contributor II
Hello,

The issue was caused by a hung up javaw.exe which is normally used by ArcGIS Server. This javaw.exe process started working independently of the ArcGIS Server and using port 4000. That was the reason for the error "Failed to start the server machine ''. Error while starting AppServer. Required port '4000' already in use."

To resolve the issue followed the below steps:-
- Stop ArcGIS Server Service which terminates all the ArcGIS Server related processes and restart the service.

- If you found and hung up javaw.exe process running from Windows Task Manager > Processes tab. Terminate the javaw.exe process manually from Task Manager and start the ArcGIS Server Service from Windows services panel.

Hope this helps!
New Contributor

Thanks it helps.

Reply
0 Kudos
New Contributor

Really appreciate your reply.I follow your instructions and the problems was perfectly resolved.Thanks again

Reply
0 Kudos
New Contributor II

I follow your instructions and the problems was perfectly resolved thanks

Reply
0 Kudos
New Contributor
I have also the same problem..

Failed to start the server machine 'LOCALSERVER'. Error while starting AppServer. Required port '4,000' already in use.'
Those error appear when I was trying to start services that already defined

I install ArcGis Server on Windows server 2013.

Can anyone help me ? Thank you
Reply
0 Kudos
New Contributor
SEVERITY STATUS CODE DESCRIPTION NAME TYPE
High Unresolved 00092 The ImageDifferenceThresholdedCleaned/diff_tempg parameter is missing a syntax dialog explanation in the item description ImageDifferenceThresholdedCleaned Tool
Reply
0 Kudos
Honored Contributor
Hello,

The issue was caused by a hung up javaw.exe which is normally used by ArcGIS Server. This javaw.exe process started working independently of the ArcGIS Server and using port 4000. That was the reason for the error "Failed to start the server machine ''. Error while starting AppServer. Required port '4000' already in use."

To resolve the issue followed the below steps:-
- Stop ArcGIS Server Service which terminates all the ArcGIS Server related processes and restart the service.

- If you found and hung up javaw.exe process running from Windows Task Manager > Processes tab. Terminate the javaw.exe process manually from Task Manager and start the ArcGIS Server Service from Windows services panel.

Hope this helps!


Hi kumar,

tried the solution provided but didn�??t work

1. Start\stop the ArcGIS Server service
2. ending the javaw.exe (I couldn�??t find it among the processes)

[ATTACH=CONFIG]31117[/ATTACH]

What other issues should I consider?