Error Copying Data from SDE But Not File Geodatabase (cross network)

134
0
04-29-2020 08:50 AM
PatrickMcKinney1
Occasional Contributor III

I had a question regarding connecting to ArcGIS Enterprise Geodatabases ("SDE") using Python scripts. My goal is to copy datasets from our production database (and a file geodatabase) to a file geodatabase to our CAD network.

The enterprise database is one what we'll call "server 1."  And the file geodatabase we're copyin from is on "server 2."  I am able to copy data from a file geodatabase (server2) on our network to the CADnetwork. But it fails on SDE datasets.  The error message is about the dataset not existing or not being supported (error 732).

ArcMap nor ArcGIS Pro is installed on the CAD server running the script, but it does have ArcGIS Server installed.

When I run the Describe function on an SDE connection file on the CAD server, the "dataType" is "File." But when I run it on my computer, it is "Workspace."

Do I need to install ArcGIS Desktop, or is it potentially some other issue?

0 Kudos
0 Replies