Select to view content in your preferred language

ERROR 001887 Failed to create couchdb database once again :-)

2900
6
Jump to solution
02-03-2023 03:54 AM
MichailMarinakis1
Occasional Contributor II

Hi all, 

soo many articles have been written about this issue and yet, in our case, we are not able to solve it 😃.

Here is our status:

We have an ArcGIS Enterprise installation 10.9.1 (installed on Windows servers) for our test environment. Portal and federated hosting Server are on the same machine, datastore is on a separate one (we added datastore on a later phase). Datastore has relational and tile cache components installed. Portal and Server are behind a external load balancer, web adaptors are installed too, IWA is activated. Our security configuration allows only https protocol. We have installed valid certificates to Portal, Server, Datastore. The windows services for Portal, Server and Datastore, are running with the same Domain administrator account. This account has full access to all the windows folders with the software and configuration.

The Server and Datastore machines are added as Trusted Sites (all the names of the machines, fully qualified, DNS names, machine name etc.). 

All the related ports are open at the firewalls to all the machines and we have made sure that these ports are not used from any other application. 

We have set the ssl certificates for the couch db too! That means that this couchdb url:

https://<ds.fqdn>:29081/_utils/#login

has actually a valid certificate! (idea: when we run the Datastore tool updatesslcertificate and a tile cache component is installed, then update the couchdb certificate too). 

The above couchdb url can be accessed from hosting Server machine. The status of the noSqldatabase in datastore is OK when we validate from hosting Server. When we validate the federated hosting server from the portal, everything is OK.

We are able to publish a Vector Tile layer. 

We created a .slpk package, based on a LAS file, visualizing a point cloud. We can load this layer to ArcGIS Pro without any issues. 

We try to publish this package either from the Portal directly, by adding an item, or from ArcGIS Pro. 

In both cases it fails. There are two severe error messages in ArcGIS Server: 

  • ERROR 001887: Failed to create couchdb database.
  • Failed to create couchdb database.: Client tried to access password-protected page without proper authorization. (status code 401).

Any recommendations would be extremely useful for us 😀

 

0 Kudos
1 Solution

Accepted Solutions
MichailMarinakis1
Occasional Contributor II

Hi all, 

we found the solution! We need to set the Internet Explorer Enhanced Security Configuration to Off to all machines with arcgis server and arcgis datastore.

Internet Explorer Enhanced Security Configuration.png

 

 

 

 

 

 

 

 

 

 

 

 

I hope it will be helpful for others.

View solution in original post

0 Kudos
6 Replies
MarcGraham2
Occasional Contributor III

hi there @MichailMarinakis1 , did you manage to sort this out? We have done everything you have except for updating the couchdb specific certificate and are getting the same 001887 error.

0 Kudos
MichailMarinakis1
Occasional Contributor II

Hi @MarcGraham2 , no luck so far. 

@JonathanQuinn , please let us know if there is something we haven't foreseen. Could it be any kind of windows configuration that is mandatory to set? So far, we have done everything described here and here (bottom of the page for the second link).

ChristianStern
New Contributor III

Hi together,

although I am continuing a thread that is almost 2 months old, I'll try to offer a solution.

I just had the same problem in my freshly upgraded ArcGIS 11.1 Enterprise Portal when trying to publish a scene layer package.
I could manage to solve the problem by following Russ Robert's advice to add the datastore machine to the trusted sites on the hosting server machine: https://community.esri.com/t5/3d-questions/publish-scene-fails-error-001887-failed-to-create/m-p/478...

Best wishes

Christian

MichailMarinakis1
Occasional Contributor II

Hi all, 

we found the solution! We need to set the Internet Explorer Enhanced Security Configuration to Off to all machines with arcgis server and arcgis datastore.

Internet Explorer Enhanced Security Configuration.png

 

 

 

 

 

 

 

 

 

 

 

 

I hope it will be helpful for others.

0 Kudos
NicoLuusAU
New Contributor II

Thanks for sharing this info!

Just a quick question, when setting Internet Explorer Enhanced Security Configuration to Off did you have to reboot any of the machines or restart the ArcGIS Server / Datastore services before the changes would take effect?

0 Kudos
Thomas_Puthusserry
Occasional Contributor

This is a very useful post and steps from @RussRoberts is also very helpful.

@NicoLuusAU  if you haven't already figured this out: yes a restart of the ArcGIS Server is required (at least in my cases) but not for the tilecache VMs.

Thomas