Select to view content in your preferred language

Error 001487 publishing map service

04-21-2022 01:24 PM
New Contributor II

When trying to publish the publishing fails, the error in the log is 001487, and the message states that the service creation failed.

I am using ArcGIS Pro 2.9.2 to publish to a non-federated ArcGIS Server 10.8.1.

Failed to create the service.: Updating the server connection string for layer Street Labels failed. Attempted connection string was ENCRYPTED_PASSWORD=00022e6865742f2f55336b413561334f5a39546d35674442447a4331576e65446132684956547933392b595a6f54413d2a00;SERVER=GISDB;INSTANCE="DSID=9019b960-bd8b-4be4-85c8-794f491fa165";DBCLIENT=sqlserver;DB_CONNECTION_PROPERTIES=GISDB;DATABASE=GBAGIS;USER=imsuser;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS. Table name is GBAGIS.DBO.STNETG. Please verify the data exists on the server.

I am able to publish a service from another project fine, but some of the projects give this error when trying to publish, and it's not always the same layer that I get the error for.  The data that is being used to publish the service that was published successfully comes from the same enterprise database, using the same connection information.

I am also able to publish these services to another ArcGIS 10.8.1 server successfully.

I am also able to publish these services to the intended ArcGIS Server if I publish them using ArcMap 10.8.1.  

So, I am unable to publish this service to Server A using ArcGIS Pro, I get the above error.

I am able to publish this service to Server B using ArcGIS Pro successfully.

I am also able to publish to Server A using ArcMap successfully.

And I am able to publish another project, with data from the same enterprise db and connection info, to Server A from Pro successfully.

So it seems that publishing on both servers works, and publishing from Pro also works.  For some reason it's just some of the services with Server A / Pro that will not work.

Anything I should be looking for?  Thanks in advance for any advice / knowledge...




4 Replies
New Contributor

Hello Jeff,

Did you ever solve this issue? I am experiencing a near identical issue.

New Contributor II

Unfortunately I am experiencing this exact same issue. Hoping there's a solution to this!

0 Kudos
New Contributor III

I was having a similar issue. I was reminded to register the view with the geodatabase. On doing so, I found I had an "invalid column". The field I was using as a unique ID for the view was smallint (short). This data type apparently is not supported as a unique ID. After changing the source field to integer (long) and recreating the view, I was able to register the view with the database. That registered view finally published without error.

This might not be the problem you are experiencing; it seems this "Please verify the data exists on the server" error results from a slew of problems that are not reported on well by the error handler. But hopefully this post helps somebody!

0 Kudos
New Contributor II

I did fix this a while back, I wish I had seen the previous requests asking if I had solved it, I never got notified that there were any responses to this post.

What I did was go into  the <site>/arcgis/manager and into Site > Data Stores, where I found that there were duplicates.  I clicked on the edit tool for each one until I found the one that had the 'ENCRYPTED_PASSWORD=' that mached the one in the error, then removed it.  That fixed it.


0 Kudos