Enable Apply Edits With Global Ids on ArcGIS Feature Services

Jump to solution
07-04-2017 01:47 PM
Occasional Contributor

I have published a Feature Service on our ArcGIS Server 10.4.1 and in support section of the Feature Service URL I am seeing that the

ApplyEdits With Global Ids: false

enter image description here

can you please let me know why this is false? and how can I update it to True?

Tags (1)
12 Replies
Occasional Contributor III

@elpinguino- finally got access to my account again...sorry for the delay - but for you and for anyone else who has this issue - what I mean is this:

Remove index:


Add index:



you can also go into the layer properties -in pro or arc catalog and go to Indexes. From there - delete the existing index on the GUID field and re add it but be sure to check the "UNIQUE" checkbox.

The rules to ensuring that the applyEditsWithGlobalIDs is true are as follows:

1. Check that all layers and tables have a global ID and unique constraint index on them

2. Check that all attachment tables related to each layer and table has global ids

3. Ensure the attachment table relationship USES the global id field/guid in the relationship - so check the Attachments_REL relationship class and make sure that it uses the Global ID field.

4. Ensure each attachment table has the global id unique index constraint

5. Ensure all relationships for layers in the service use global ids to participate in the relationship (including attachment relationships).


You can usually browse the /arcgis/rest/services/ServiceName/MapServer/<LAYERID> endpoint of the service for each layer to see which one is the culprit .


New Contributor III

I had to do this as well.  My issue was I was importing a feature class with attachments and GlobalIDs already in place.  I had to build a brand new feature class replicating the existing one.  Then I needed to give it GlobalIDs, enable attachments and also enable archiving for the value to change to 'ApplyEdits with GlobalIDS : true'.  After that was successful I appended my old data that I downloaded from AGOL into this new feature class.

0 Kudos
New Contributor II

Activate synchronization (update disconnected with synchronization).

All right !

0 Kudos