Embedded dashboard in enterprise site requires two logins - Invalid 'X-Frame-Options'

792
6
07-11-2019 08:32 AM
FredSpataro
Occasional Contributor III

Hi All, 

I'm building out a bunch of Enterprise Site pages that have an embedded Ops-Dashboards.  When we access the site page, we are prompted to login to the site (expected and good) and then login again to the dashboard - not excepted and not good.  And even when the site page opens again in a new tab, the site has a cached login and opens the page without the login prompt but still prompts for the login on the dashboard. This seems like a bad workflow and users are definitely not going to like it.  Is there a bug?  Is there specific way to embedded secure content into the site page so it doesn't require two logins?  

Setup:

  • Version 10.7
  • Separate portal/server and web-adapter machines
  • Site and dashboard are on the same portal:
  • Chrome/Edge/Firefox all display the same behavior. 
    • Invalid 'X-Frame-Options' header encountered when loading ... 'ALLOW-FROM https://server' is not a recognized directive. The header will be ignored.

Seems similar to this: https://community.esri.com/thread/87825 and could be that there's a new header requirement: https://stackoverflow.com/questions/30731290/how-to-set-x-frame-options-allow-from-in-nginx-correctl...

thanks

Fred

0 Kudos
6 Replies
CameronMcArtney
Esri Contributor

Hey Fred Spataro did you have any luck with this? I am having the same issue. 

0 Kudos
FredSpataro
Occasional Contributor III

Hi Cameron, 

I was not able to solve this one.  We ran into a few more issues with OpsDashboard and decided to go with a custom dashboard instead. Sorry I can't be more help.

Fred

CameronMcArtney
Esri Contributor

Thanks Fred, I'll let you know if I find a solution.

0 Kudos
parksh
by
New Contributor II

Hello Cameron,

 

I have a same question with you.

Did you find any solutions? 

 

Su-hyeon.

0 Kudos
CameronMcArtney
Esri Contributor

Unfortaunately not yet @parksh will undate here if i do!

0 Kudos
ChrisRoth
New Contributor

I am having the same issue with a customer site. Embedded dashboards in a dashboard all require logging in over and over...

0 Kudos