Editor Tracking with Versioning

928
2
02-18-2022 12:51 PM
zstanley
New Contributor II

Hi All,

I'm working from a database I'm the DBO on and I've connected to the sde database with OS authentication. When I create a new version the owner is DBO. When I make edits in the version I'm noticing that editor tracking isn't working and GUIDs aren't being created for new features. Any insight as to why this might be happening? I'm wondering if it is related to roles/users in SQL management studio. 

Any insight here would be great.

Thanks,

Zac

Tags (3)
0 Kudos
2 Replies
KimGarbade
Occasional Contributor III

So many things it could be.... do you mind if I ask you a bunch of questions (some depend on you having SQL Server Management Studio).  Forgive me if some of them seem silly.

1) What version of SDE was used to create your database (below is an image of a query that will tell you) and what version of Esri client (either ArcMap or ArcGIS Pro) are you using?

KimGarbade_0-1645288376868.png

2) Is the data you are editing registered as versioned? 

3) Did you add the windows authorized account your using to the database using SQL server tools or Esri's "Create Database User" tool....both? 

4) Is your windows authorized login a member of your SQL Server instance's sysadmin fixed server role? 

5) If you look at the database tables in SQL Server does dbo own the SDE schema (the tables will say "SDE_" in the name)?

It seems like your windows authorized login has the permissions required by SQL Server to create records in the database (I.E. add features, create versions), but your Esri client doesn't know how to handle them, almost like your are editing the table directly in SQL Server and not through an Esri desktop product.

0 Kudos
zstanley
New Contributor II

Kim-

Thanks for the response. Answers to your questions below:

 

1) What version of SDE was used to create your database (below is an image of a query that will tell you) and what version of Esri client (either ArcMap or ArcGIS Pro) are you using? Looks like the release is SDE 10.7.1 and I'm using ArcGIS Pro 2.9.0.

2) Is the data you are editing registered as versioned? Yes

3) Did you add the windows authorized account your using to the database using SQL server tools or Esri's "Create Database User" tool....both? This was likely done using the 'Create Database User' tool

4) Is your windows authorized login a member of your SQL Server instance's sysadmin fixed server role? I think, yes. I ran the attached query.

It results in this:

campus\zstanley U WINDOWS_LOGIN 0 08/21/2021 09/23/2021

5) If you look at the database tables in SQL Server does dbo own the SDE schema (the tables will say "SDE_" in the name)? Yes, see screenshot.

Thanks in advance for your help!

 

0 Kudos