Editor Tracking Only Recording a Single Time

742
6
Jump to solution
05-02-2017 10:29 AM
MitchHolley1
MVP Regular Contributor

The issue we're having is only a single date is being recorded in the 'last_edited_date' & 'created_date' fields for Editor Tracking when the data is being synced back to the server (see below).  When in reality, the field is editing features about every 5-10 minutes.  Editor Tracking is enabled on every FC and table in the enterprise geodatabase, and UTC time is being recorded.  Is there a way to change this?  We're using Feature Services with ArcGIS Collector for disconnected editing.  We recently started using ArcServer 10.5 and SQL Server 2016.  The enterprise geodatabase is 10.5 as well.

Reply
0 Kudos
1 Solution

Accepted Solutions
VickyShort
Occasional Contributor

We upgraded on Friday to ArcGIS Server 10.5.1 and editor tracking is now working. The bug was raised by ESRI UK after we logged a support case. I have just looked it up and it hasn't gone live yet.

ESRI email:

The following bug has been logged against version 10.5: BUG-000107174 : When a replica from a sync enabled feature service with editor tracking enabled is synchronized, the editor tracking fields (created_date and last_edited_date) record the date/time that the replica was synced rather than the date/time that the feature was created/edited. The workaround is to upgrade to 10.5.1. You will be able to sign up for notifications by searching for the bug number on the esri inc. support site when it goes live on the public site: http://support.esri.com/en/ .

View solution in original post

6 Replies
VickyShort
Occasional Contributor

Hi,

Did you work this out? We are having a similar problem since upgrading to 10.5 and SQL Server 2016. The editor tracking fields are being populated but on with the date & time the offline edits are synced opposed to the date & time features were create/edited in the field.

Thank you

Vicky

Reply
0 Kudos
MitchHolley1
MVP Regular Contributor

No, this has not been resolved. 

Reply
0 Kudos
VickyShort
Occasional Contributor

BUG-000107174 : When a replica from a sync enabled feature service with editor tracking enabled is synchronized, the editor tracking fields (created_date and last_edited_date) record the date/time that the replica was synced rather than the date/time that the feature was created/edited.

The workaround is to upgrade to 10.5.1.

MitchHolley1
MVP Regular Contributor

Upgrade our ArcServer to 10.5.1?  Could you send a link to the ESRI site where you found the BUG info, please?  Thanks so much for your help!

Reply
0 Kudos
VickyShort
Occasional Contributor

We upgraded on Friday to ArcGIS Server 10.5.1 and editor tracking is now working. The bug was raised by ESRI UK after we logged a support case. I have just looked it up and it hasn't gone live yet.

ESRI email:

The following bug has been logged against version 10.5: BUG-000107174 : When a replica from a sync enabled feature service with editor tracking enabled is synchronized, the editor tracking fields (created_date and last_edited_date) record the date/time that the replica was synced rather than the date/time that the feature was created/edited. The workaround is to upgrade to 10.5.1. You will be able to sign up for notifications by searching for the bug number on the esri inc. support site when it goes live on the public site: http://support.esri.com/en/ .

View solution in original post

MitchHolley1
MVP Regular Contributor

Thanks so much for your help and insight, Vicky!

Reply
0 Kudos