Edit Portal Services URL

7628
11
Jump to solution
06-22-2018 03:28 PM
forestknutsen1
MVP Regular Contributor

When I federated our portal install I entered the wrong url for the services. Is there a way to edit this with out un-federating the server? 

1 Solution

Accepted Solutions
forestknutsen1
MVP Regular Contributor

Okay, so we restored the sever from a snapshot to a point before the error was made. Then federated again. 

View solution in original post

0 Kudos
11 Replies
forestknutsen1
MVP Regular Contributor

Manually edit the Portal's Federation with ArcGIS Server by going to the Portal Sharing Directory (/portal/sharing/rest) > Home > Portals > Self > Servers > Server ID > Update Server.
1. https://xxxxxxx/arcgis/sharing/rest
2. Portals>Self>Servers
3. Click on Server ID
4. Corrected URL, reentered Admin URL (required)

0 Kudos
forestknutsen1
MVP Regular Contributor

I tried the above steps and shared a new service but it does not seem to be updating the service urls

0 Kudos
JonathanQuinn
Esri Frequent Contributor

That workflow doesn't update any existing services. You'll need to update the URLs using the Sharing API.

forestknutsen1
MVP Regular Contributor

Thanks Jonathan. I understand that it would not fix services that already have been shared with portal. But when I share a new service from server manager to portal it should have the updated url, yes? Because it is still not working...

My coworker (who has a lot more knowledge of portal then me) feels that there is no way to recover from this situation, and we just need to spin up a new server and config. 

0 Kudos
forestknutsen1
MVP Regular Contributor

Okay, so we restored the sever from a snapshot to a point before the error was made. Then federated again. 

0 Kudos
CollinJohnston
Occasional Contributor III

Jonathan, Can you share more details about using the Sharing API to update? I believe I have made the same mistake and need to update the ArcGIS Server services url. 

I don't mind republishing services once the change is made but i'm unclear as to where I would make this change. Can you add any details to how I would accomplish this? 

0 Kudos
JonathanQuinn
Esri Frequent Contributor

1) Log into the Sharing API as an Administrator through https://machine.domain.com:7443/arcgis/sharing/rest

2) In your account information page, there will be an Org ID property with a link to 0123456789ABCDEF. Click on that link

3) All the way at the bottom, click on Servers under the Child Resources section

4) Click on the Server ID link and then Update Server

5) Enter the new services URL and the existing Admin URL and click Update.

You'll then need to go through everyone's content and update any URLs to any services that are not hosted services

1) Go into a users content in the Sharing API, (https://machine.domain.com:7443/arcgis/sharing/rest/content/users/<user>/items/ for example)

2) Select a non-hosted service and at the bottom, select Update Item

3) Enter the new URL in the URL parameter box

You can use the Python API to traverse through each user and their content, find all non-hosted services and update the URLs if you want. You'll need to republish hosted services for the URL to update.

CollinJohnston
Occasional Contributor III

This is great! Thank you. But, and you knew there would be a but.....  

3) All the way at the bottom, click on Servers under the Child Resources section

I think i'm uncovering my issue here slowly. There is no option for Servers? 

0 Kudos
JonathanQuinn
Esri Frequent Contributor

So under https://machine.domain.com:7443/arcgis/sharing/rest/portals/0123456789ABCDEF you don't see Servers? This is what I see when I'm signed in as an Administrator:

Make sure whatever account you're using is an Administrator within the Portal.