Edit NON-geodatabase spatial tables from PostGIS using ArcGIS for Server Feature Services

3153
1
08-07-2015 05:38 AM
JanCreupelandt
New Contributor III

Hi,

I tried to edit a spatial table via a feature service in arcgis.com, but it doesn't seems to work.

I use;

- postgresql 9.2.2

- postgis 2.0

- a "non-geodatabase", I simply created a database in Postgresql and create a feature class with ArcCatalog. so the table contains an autoincrement objectid field, and is stored with the PG_Geometry spatial type.

- the feature class is added in ArcMap as a simple query layer and published to ArcGIS for Server 10.2.1 as a Mapservice with feature access capability. the user I use is the owner of the table.

A simple load via ArcCatalog is possible, but when editing the feature service via e.g. a javascript client (like arcgis.com), the data is not updated. Fiddler tells me the request was successful executed, but nothing is added in the database. updating an attribute of an existing feature is possible, so it seems only updating or creating a new geometry causes the problem. I also see no error log in the arcgis server logs, nor in the postgres logs.

Do I miss a setting/configuration ?

Kind regards,

Jan Creupelandt

0 Kudos
1 Reply
JanCreupelandt
New Contributor III

seems it is a bug in 10.2.1 and solved in 10.3.