Different display for Map server and Feature server

288
9
07-02-2019 02:54 AM
HoangHiep
New Contributor II

Hi,

I'm using ArcGIS server 10.3. I create a map service and enable "Feature access", but when I review, my feature layer display on wrong place on the map (map server display perfectly)

Anyone with ideas? Srr for my bad English and thank you

enter image description here 

0 Kudos
9 Replies
TanuHoque
Esri Regular Contributor

do you see the same problem when you add a sublayer from the map services as a feature layer?

e.g. adding a layer using a url like this: http://myserver/arcgis/rest/VNP/MapServer/0

HoangHiep
New Contributor II

Thank you Tanu, I create a map service from a feature class(set custom CRS) then enable "feature access" to create feature layer but I dont know if I missed something?

My layer's url:

http://localhost:6080/arcgis/rest/services/VNP/FeatureServer/0

http://localhost:6080/arcgis/rest/services/VNP/MapServer/0

Thks in advance

0 Kudos
TanuHoque
Esri Regular Contributor

Thanks Hoang

I understand you used the following URL when you added the feature layer. Pls correct me if I'm wrong

http://localhost:6080/arcgis/rest/services/VNP/FeatureServer/0

Could you pls add a feature layer with this url?

http://localhost:6080/arcgis/rest/services/VNP/MapServer/0

I just want to know whether using map service url will help in this case. Also checkout the query request that goes out to the server to fetch those geometries. Do you see outSRS specified in the request?

HoangHiep
New Contributor II

Thks Tanu,

I try to use both 2 urls, 

when i use ...VNP/FeatureServer/0 (1) it's displayed on wrong place

when i use ...VNP/MapServer/0  (2) it's display exactly

But I have to use (1) because I want to use feature service to edit/create the features

When I create request (1), I see the request:

feature layer json:

{  "currentVersion": 10.3,  "serviceDescription": "",  "hasVersionedData": false,  "supportsDisconnectedEditing": false,  "syncEnabled": false,  "supportedQueryFormats": "JSON, AMF",  "maxRecordCount": 1000,  "capabilities": "Create,Delete,Query,Update,Uploads,Editing",  "description": "",  "copyrightText": "",  "spatialReference": {"wkt": "PROJCS[\"VN_2000_UTM_Zone_48N_1050\",GEOGCS[\"GCS_VN_2000\",DATUM[\"D_Vietnam_2000\",SPHEROID[\"WGS_1984\",6378137.0,298.257223563]],PRIMEM[\"Greenwich\",0.0],UNIT[\"Degree\",0.0174532925199433]],PROJECTION[\"Transverse_Mercator\"],PARAMETER[\"False_Easting\",500000.0],PARAMETER[\"False_Northing\",0.0],PARAMETER[\"Central_Meridian\",105.5],PARAMETER[\"Scale_Factor\",0.9999],PARAMETER[\"Latitude_Of_Origin\",0.0],UNIT[\"Meter\",1.0]]"},  "initialExtent": {   "xmin": -1.0470267216494847E7,   "ymin": -3339428.0068728523,   "xmax": 2.0227267216494847E7,   "ymax": 11001210,   "spatialReference": {"wkt": "PROJCS[\"VN_2000_UTM_Zone_48N_1050\",GEOGCS[\"GCS_VN_2000\",DATUM[\"D_Vietnam_2000\",SPHEROID[\"WGS_1984\",6378137.0,298.257223563]],PRIMEM[\"Greenwich\",0.0],UNIT[\"Degree\",0.0174532925199433]],PROJECTION[\"Transverse_Mercator\"],PARAMETER[\"False_Easting\",500000.0],PARAMETER[\"False_Northing\",0.0],PARAMETER[\"Central_Meridian\",105.5],PARAMETER[\"Scale_Factor\",0.9999],PARAMETER[\"Latitude_Of_Origin\",0.0],UNIT[\"Meter\",1.0]]"}  },  "fullExtent": {   "xmin": -5122600,   "ymin": -10001100,   "xmax": 14879600,   "ymax": 10001100,   "spatialReference": {"wkt": "PROJCS[\"VN_2000_UTM_Zone_48N_1050\",GEOGCS[\"GCS_VN_2000\",DATUM[\"D_Vietnam_2000\",SPHEROID[\"WGS_1984\",6378137.0,298.257223563]],PRIMEM[\"Greenwich\",0.0],UNIT[\"Degree\",0.0174532925199433]],PROJECTION[\"Transverse_Mercator\"],PARAMETER[\"False_Easting\",500000.0],PARAMETER[\"False_Northing\",0.0],PARAMETER[\"Central_Meridian\",105.5],PARAMETER[\"Scale_Factor\",0.9999],PARAMETER[\"Latitude_Of_Origin\",0.0],UNIT[\"Meter\",1.0]]"}  },  "allowGeometryUpdates": true,  "units": "esriMeters",  "documentInfo": {   "Title": "",   "Author": "",   "Comments": "",   "Subject": "",   "Category": "",   "Keywords": ""  },  "layers": [   {    "id": 0,    "name": "ARC.VNP"   }  ], "tables": [],  "enableZDefaults": false }
0 Kudos
TanuHoque
Esri Regular Contributor

Thanks Hoang Hiep‌.

It looks like bug to me in feature service. I see you are using an older version (10.3) of arcgis server, pls reach out to Esri support to find out whether it is fixed in a newer version or not.

GaryMacDougall
Occasional Contributor

Hi Hoang Hiep

I’ve not seen an issue like that before – at least not that I can remember.

 

Seems you have a custom projection – not sure how that is playing into things.

 

I think we would need the data and map that was published to see what is happening. If you could work with support to get us that info it would help us look into this case further.

 

thanks

HoangHiep
New Contributor II

Thk Gary and Tanu,

I cant public my service because I installed on my PC, 

I created my service by following steps:

- I create a feature class in arcmap catalog then load my shape file into this feature class

- Set my custom XY coordinate for this feature class

- In Table of Contents, right click then add Data, then choose this feature class

- Share as service and pick "feature access"

Do I miss something to create feature service?

Its great if you can add my skype (chatfa7) then remote my PC to see what going on

Thank in advance for your help again 

0 Kudos
TanuHoque
Esri Regular Contributor

Hoang,

Please contact Esri Support. They will be able to help

Thanks.

0 Kudos
HoangHiep
New Contributor II

Hi, thks for your support, I resolve this problems.

It causes of I cant set XY coordinates for feature class that has custom projected coordinate system, so I have to transform it to geo coordinate system (WGS84):

I use transform and project --> project tool in Arc toolbox to create a projected feature class -> publish service --> it works

0 Kudos