Datastore web server not started

363
2
01-25-2021 03:28 AM
PierreLarondelle
New Contributor III

Hello everyone,

I'm facing a problem after upgrading the whole enterprise component (piece by piece) following esri's best practices and advices from our local reseller. Version 10.7.1 => 10.8.1

Everything went right until the datastore. The upgrade fails, I had to uninstall /reinstall, it still fails to work, etc ... So that I decided to stop fighting as we didn't really need this component.

After a while I decided to take a new look on it and get it to work. We've got 3 servers one for Portal/Server, another for DBMS (PostgreSQL) and a third one dedicated to datastore (with option to add a standby datastore on the first server as RAM is no bottleneck).

I installed datastore only on the third server (Win server 2019 - 12Gb RAM). When it comes to configure datastore post install, I get a message noticing that it failed to grant permission (see attachment). Ok, no big deal, I gave full permissions on every folders the datastore may need on both servers (Server + Datastore) to allow the configuration. Result : nada, it won't configure ...

I stopped the service, deleted the "F:\AGSENTCONTAINER\arcgisdatastore" created folder, restarted the service an retry : No more luck.

As it may be another problem, I tried to install the datastore on first server (Server). Install ok, then the post config web page stay blank : "err_connection_refused". Maybe a certificate issue ? Ok, let's change the self signed for a domain one. Guess what ? blank page ...

Cause I don't give up easily, I investigate and found that the datastore's web server was not working. No matter I try, even starting the tomcat from cli (without error message) it doesn't responds.

As I don't find any clear log informations, I'm a bit lost. Crawling through community's posts shows that I'm not the only one ...

I don't know what happened with 10.8.1 (10.7.1 was rock solid) but the I regret everyday the upgrade for what was supposed to be for a better. I will not dwell on the other problems like recurring token issues  etc ... but I'm a little disappointed.

1°) Has anyone encounter a non starting datastore's web server ?

2°) Any ideas on what may lead to the insufficient permissions while "Everyone" has full access (for testing purpose) ?

Have a nice day

Tags (1)
0 Kudos
2 Replies
Naveen
by Esri Contributor
Esri Contributor

Hi PierreLorandelle, 

The error message could be related to the reasons as mentioned in this tech article: https://support.esri.com/en/Technical-Article/000019298

Also, please use the ArcGIS server URL as  https://gisserver.domain.com:6443 in the Datastore configuration wizard.

0 Kudos
PierreLarondelle
New Contributor III

Thanks Naveen,

I already tried what is suggested in Esri's doc but no luck. The problem is that the datastore's web page server is not starting, therefore I don't even have access to the config page and can't proceed further.

There's apparently no port conflict, I can start and stop the tomcat with cli but no way to get the config page showing in browser.

I've also done a clean desinstall and reinstall, doesn't help too. It's really strange.

Domain Certificates are up to date and working. 

0 Kudos