Database user name and current user schema do not match - postgres [SOLVED]

837
0
04-13-2020 02:28 PM
DrewPhillips3
New Contributor II

Edit: choosing 'sde' as the user name under 'connection properties' has allowed me to create feature datasets and add feature classes. Maybe the problem was that I created a feature dataset as the default superuser 'postgres' and tried to add feature classes to that?

I saw a question similar to this but it was for SQL server.

I'm a postgres novice trying to move data into a geodatabase within postgres. I was able to create a gdb in postgres on my local machine but when I try to transfer data from a network drive to the gdb I get the error message in the title of this post.

What I've tried:

- ensuring that I'm connected as postgres (superuser generic name)

- elevating privileges for user 'sde'

- in pgadmin4, entered:

 - "grant usage on schema public to sde;"

 - "grant usage on schema sde to sde;"

It seems that I have to use the sde login to load in data... do I have this right?

Thanks for your help!

current users

0 Kudos
0 Replies