Custom Print Task Map Url is Blank Issuse

2274
2
04-20-2016 09:23 PM
Santhosh_KumarRamanathan
New Contributor

Hi guys,

I am using esri proxy and Web Adaptor in my application trying to access the gis server custom print service in another machine.

Thing is that i am able to print map in arcgisoutput directory but when i try to access the print map by print  javacript api i am getting blank map. with http error 499 in console.

I even tried running ,locally the URL by removing  web adapter name by using default name and port on gis server machine ,but i am still getting blank  and same error  .

Any suggestions will help

Thanks.

0 Kudos
2 Replies
DavidBlanchard
Esri Contributor

If you are printing on a different server than the one hosting your data, make sure the printing server has access to the layers in the hosting server.

Also, if you are using the proxy to authenticate yourself with the layers, you will not be able to print this layers as the printing server will not be authenticated.

0 Kudos
Santhosh_KumarRamanathan
New Contributor

Hi,

Hosted data is coming from ArcSDE and it is added to GIS Server. I am able to print map result in that arcgis output directory of print service. Physically map print is present. But when i try to open the print map result through URL of web adpator or arcgis server . browser is blank

Web Server/Web Adpator/Arcgis proxy : ( checked from application print javascript  api ) http://<WA>/emidgis/rest/directories/PrintOutput/GP/Print_GPServer/_ags_01741f04514543c996bc1bc701a3...

GIS Server(checked locally)

http://<gis server> :6080/arcgis/rest/directories/PrintOutput/GP/Print_GPServer/_ags_01741f04514543c...

Both  are blank in URL  with error "Failed to load resource: the server responded with a status of 499 ()"

but print map is present in physical path of GIS server directory i.e "D:/.../../PrintOutput/GP/Print_GPServer/_ags_01741f04514543c996bc1bc701a36b1a.pdf "

0 Kudos