Custom Export Web Map tool working intermittently due to ArcSOC error

402
7
11-19-2021 05:02 AM
Slee63
by
New Contributor II

I have created a custom print from the Export Web Map tool and published to ArcGIS Server 10.8.1. Everything went according to what ESRI documented. Initially, everything worked, then it worked intermittently, now it stopped working. Executing the Print on the Web App Builder results in MAP_ONLY being printed while the custom print does not. When I search the server log, it showed an error on " ArcSOC process for this service may not have enough memory alloted". I have not encountered this error before. On googling on ArcSOC, there seem no consensus on memory allocation or what caused the process to consume that much memory. I only have 1 layout published with the Export Web Map tool with basic map elements, nothing fancy to consume memory. I have attached screen shots to illustrate.

Appreciate if anyone can help as I'm trying to get the print server to work. Thanks.

0 Kudos
7 Replies
ABishop
Regular Contributor III

Hello,

For starters, did you try increasing the heap size on the server as the error message suggested?

Amanda Bishop, GISP
0 Kudos
Slee63
by
New Contributor II

Yes, I have increased 512 M. I'm not sure if that is a wise solution though. How much more can we increase?

0 Kudos
ABishop
Regular Contributor III

Here is some information about heap size adjustments:

https://enterprise.arcgis.com/en/server/10.3/publish-services/linux/geoprocessing-service-settings-a... 

Amanda Bishop, GISP
0 Kudos
Slee63
by
New Contributor II

Yes, that is the article I have been using to resolve the error. It doesn't say how much to increase, so I'm now on trial and error.

0 Kudos
ABishop
Regular Contributor III

It says SOC max is 64 MB.  Also, another suggestion is to contact ESRI support.  They may be able to assist with additional troubleshooting on your server or the service.  I have seen where a BUG has been uncovered or a patch is needed.  Have you searched the BUG report for this issue?  See link below for site to perform a search.

https://support.esri.com/en/Search-Results#search?q=arcgis-server%20heap%20size&content-type=Bugs 

 

Amanda Bishop, GISP
0 Kudos
Slee63
by
New Contributor II

No, it says the default SOC max size is 64M. "By default, the application server is set to 256 MB and the SOC maximum to 64 MB." You can increase the SOC max size. I'm still trouble shooting, will reach out to them in a bit.

ABishop
Regular Contributor III

OK I must have read that wrong.  My apologies.  Well... I hope you find out how to resolve this soon!  

Amanda Bishop, GISP
0 Kudos