Could not access any GIS Server machines

845
1
11-30-2019 09:13 AM
anjelinaponkerat
Occasional Contributor II

I,m using Arcgis server 10.5 and web adaptor, some times ARCGIS return this error:

"Could not access any GIS Server machines. Please contact your system administrator."

I checked my windows event viewer and found this log:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 11/30/2019 10:51:47 AM
Event time (UTC): 1/30/2019 10:51:47 PM
Event ID: a4c1a824b93c4963bb13196235596ce3
Event sequence: 268
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/igis-2-131605141222797892
Trust level: Full
Application Virtual Path: /igis
Application Path: C:\inetpub\wwwroot\igis\
Machine name: gggrrrtt 

Process information:
Process ID: 30944
Process name: w3wp.exe
Account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0

Exception information:
Exception type: HttpException
Exception message: Server cannot set content type after HTTP headers have been sent.
at System.Web.HttpResponse.set_ContentType(String value)
at System.Web.UI.Page.SetIntrinsics(HttpContext context, Boolean allowAsync)
at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at System.Web.HttpServerUtility.ExecuteInternal(IHttpHandler handler, TextWriter writer, Boolean preserveForm, Boolean setPreviousPage, VirtualPath path, VirtualPath filePath, String physPath, Exception error, String queryStringOverride)



Request information:
Request URL: https://localhost:443/gis/rest/services/new1/ImageServer/tile/9/215/335
Request path: /igis/rest/services/new1/ImageServer/tile/9/215/335
User host address: *.*.*.*
User:
Is authenticated: False
Authentication Type:
Thread account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0

Thread information:
Thread ID: 65
Thread account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0
Is impersonating: False
Stack trace: at System.Web.HttpResponse.set_ContentType(String value)
at System.Web.UI.Page.SetIntrinsics(HttpContext context, Boolean allowAsync)
at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at System.Web.HttpServerUtility.ExecuteInternal(IHttpHandler handler, TextWriter writer, Boolean preserveForm, Boolean setPreviousPage, VirtualPath path, VirtualPath filePath, String physPath, Exception error, String queryStringOverride)



whats the reason?

0 Kudos
1 Reply
HarroldSompotan
Esri Contributor

Hi anjelina ponkerat‌,

Have you reviewed the KB arcticle below?

Error: Could not access any GIS Server machines. Please contact your system administrator 

It appears the ArcGIS Web Adaptor is starting before ArcGIS Server, and is unable to establish connection to the machine. Hence ArcGIS for Server is generating those logs.

If you need further assistance, I suggest opening a case with Tech Support.

Hope this helps.

0 Kudos