Clip and Ship GP service fails to clip and download tiff raster

10-01-2020 08:04 AM
Esri Contributor

Hello everyone.

I wanted to create a GP service that will be able to clip and download raster data for a certain user defined area. In order to accomplish this I decided that the Extract Data task model would be appropriate. So I used this model to create a geoprocessing service on ArcGIS Server.


When executing the tool from ArcGIS Server, I have noticed that when I select smaller area, it works just fine, but when I draw larger polygon in order to clip larger area from the source raster there is a problem, the output is only few KB and if I try to open it in ArcMap, nothing is displayed. This happens when tiff is chosen as an output format. I checked the GP results window and I think the message is misleading (Invalid extension), which is definitely not the case since the exact same tool with the exact same settings works perfectly fine when I select smaller area AND tiff is supported by default in the Extract Data Model from ESRI.

I have tried this with two different ArcGIS Servers (10.6 and 10.7.1) installed on different environments and I still get the same results. 

I was thinking that it might have to do something with the size of the output, but even stranger, when I choose file geodatabase raster as output format, no problem at all, it works perfectly no matter how small or large the area of interest is!

Anyone else have this problem? Can someone suggest a solution?

Best Regards,

Tome Jovanovski

GDi Skopje - Official ESRI distributor in Macedonia.

0 Kudos
1 Reply
New Contributor

I am having the same problem with tiffs.  I'm trying to use the published service I have created in a map application, and it generates a tiff, but when I bring it into a map, nothing shows up.  

0 Kudos