Changes to coded values could not be saved in ArcMap while I see them saved in Pro

528
4
05-28-2021 12:40 PM
MaximeDemers
Occasional Contributor III

Hi,

Im facing a weird problem with coded values. Im trying to change the description inside a domain in ArcMap. I can save it without any error, but when I close and re-open ArcMap, I see the change was not saved.

 

However, if I inspect the same domain in Pro, I see the changes in the description just  as I had modified them in ArcMap.

 

Here is some of the specifications of our installations:

ArcMap 10.6.1

Pro 2.7.1

SQLServer 2012 on Windows Server 2012R2

 

Any idea what could be tried to resolve this?

 

0 Kudos
4 Replies
JoeBorgione
MVP Esteemed Contributor

Stop using ArcMap and use ArcGIS Pro only?  Just a thought!

All seriousness aside; what happens if you restart your computer and then fire up ArcMap?

That should just about do it....
0 Kudos
MaximeDemers
Occasional Contributor III

Thank you, but we cannot stop using ArcMap for some projetcs right now. I did try to reboot ArcMap and SQLServer as well without success

0 Kudos
JoeBorgione
MVP Esteemed Contributor

That is really odd.  What if you make the change in Pro?  Does ArcMap see them? 

I don't have ArcMap installed or I would try to replicate the problem.

 

That should just about do it....
0 Kudos
George_Thompson
Esri Frequent Contributor

So part of the issue may be that SQL Server 2012 is supported with ArcMap 10.6.x but not with ArcGIS Pro 2.7.x. : https://desktop.arcgis.com/en/system-requirements/latest/database-requirements-sqlserver.htm

Though I find it weird that you can see everything in Pro with no issues.

What is the version of the Enterprise Geodatabase being used?

--- George T.