change server url in enterprise

77
3
01-06-2020 09:13 AM
Highlighted
New Contributor II

We setup Enterprise and everything worked fine. IT changed the name of the server and we now have some errors we need to fix. One is our local hosts no longer work. We get the 404 error for http://localhost/server/webadaptor and http://localhost/portal/webadaptor 

Do we need to reinstall Enterprise or is there a way to fix the url's?

Thank you.

Tags (1)
Reply
0 Kudos
3 Replies
Highlighted
Esri Frequent Contributor

The best/easiest approach is see if your IT staff and revert the change and leave the hostname as it is. If the domain changes, then I can see how that isn't an option. Re-wiring everything once the FQDN changes can be challenging, as the URL is written into a significant number of config files.. You may be able to work with Support to guide you through it, but be aware that change the hostname of Enterprise isn't technically supported, so they may be limited in what they can help with.

Highlighted
New Contributor II

I think the factor to stress here is that while it may be possible to workaround this with some file manipulation and hackery, it is not supported and can likely lead to issues in the long-term. It is my understanding, as John mentioned, that best practice would be either to revert the change or to reinstall and reconfigure Enterprise. It'll be worth it to avoid the hours/days it can take to remedy the issues that would arise from any other workarounds if something breaks. 

Reply
0 Kudos
Highlighted
New Contributor II

Hi Brian,

When you install your web adaptor you should use the DNS name that you intent to use for your system because localhost will only be available on the server that the application is installed on.

If you don't have content or customisation then Like Jonathan indicate the best option is to reinstall the environment.

If you get a 404 on this url http://localhost/server/webadaptorit might indicate that you have a problem with IIS or you are trying to access the service from another server can you access your server on http://localhost:6080/arcgis/manager or http://my_server_name.local_fqnd:6080/arcgis/manager?

You should also use Https instead of http for any production system.

Reply
0 Kudos