Cannot publishing feature class to AGOl from ArcSDE

09-18-2014 12:26 PM
New Contributor

Using ArcGIS desktop 10.2.2, I was able to publish two feature services to ArcGIS Online from an SDE (SQL Server 2012 Standard 64 bit), OS version (server 2008 R2 64-bit). The SDE is versioned and contains views.


The problem is I cannot publish feature class services. It gets hung up the whole day. The progress bar will proceed to the middle and just stay there the whole day with no feature class published. The feature services contain complex symbols that are located in my network drive. Prior to publishing I had fiddler2 open, it seems to have issues with I do have adobe creative cloud suite membership, but all of those adobe applications were closed and I was logged off out of my adobe account. Actually they were never opened. Even when I tried "save a service definition file" and "stage", it would still get hung up.


However when I exported the feature class to a file geodatabase and used the same complex symbols, I was able to publish the feature class immediately.


Has anyone encounter this problem? What is the best alternative solution. What I would like to do is publish all of the feature services from the SDE to AGOl, create a web map, make edits using ESRI Collector App and have it sync directly with the SDE. 


Or is this a situation where I should just export everything to a file geodatabase, publish the services to AGOl, create the web map, use ESRI collector app to make the modification, then sync file geodatabase with the SDE. Or should I publish the feature services to ArcGIS Server and somehow connect it to AGOl then use the ESRI collector to make modification which would result in automatically synchronization with the SDE?






0 Kudos
0 Replies