Cannot load hosted feature layer to the Web Map

472
2
08-27-2021 12:42 AM
YoojungYang
New Contributor II

Hello, 

I'm using ArcGIS Enterprise Portal 10.8.1 and after I tried to load a huge(It's about 1gb but have many vertices) feature layer as hosting layer the Data Store is not working properly. 

Referenced layers has no problem. 

Then I try to open the Rest url it's empty and not able to add to the webmap. I checked SSL connection between Portal, DataStore and Server. Also tried unregister relational Datastore(leave tile Cache as is) >> register>> restore the DataStore w/ the most recent backup. and it's successfully validated in the Server Manager. 

Still Hosted layer is not working. The error message on the serve manager is like the attachment. 

Any hint would be helpful. 

2 Replies
HenryLindemann
Esri Contributor
Hi there might be a corrupt folder in your hosted folder D:\arcgisserver\config-store\services\Hosted this sometimes happens when a user tries to publish and it crashes, look for empty folders or that large service and remove it. Just make a backup before you start.
Regards
Henry
YoojungYang
New Contributor II

Thank you for instant response. 

I removed that large folder from the location that you designated. And I was able to delete the contents from the portal(it failed when I tried before remove the folder) 

The large services is removed but still other hosted layers are not loaded. Do I need to restart the portal, service, datastore servces? 

 

 

0 Kudos