cannot create oracle 18C geodatabase

359
1
07-18-2021 03:24 PM
abetaheta
New Contributor

Hi all, i'am trying to connect or create to an oracle database using  ArcMap but it gives me the error in the following screen.

abetaheta_0-1626646128916.png

I have tried all methods provided be ESRI here and it give me same error when try to connect to Oracle, also i use tnsnames.ora to add all information like hostname/service name/port to the connection dialog box.

- I can access and create DB's in the SQLDeveloper app with the same provided information in ArcMap.

- Also in the documentation ESRI say that to install Oracle 32bit, but I want to user Oracle 18C and it's available only for 64 (only 11g versions have 86/64bit).

- I built a Virtualbox and install ArcGIS desktop with Oracle 11g 32 bit then the connection on ArcMap successfully done, although when trying to Create Enterprise Gdb it gives me that SYS doesn't have the privileges for that.

so kindly I want a way to create and connect on an Oracle database using ArcMap.

my environment:

Win10 64 bit with domain. 16GB ram.

ArcGIS Desktop 10.8.1 Advanced

Oracle 18c

thanks

 

 

0 Kudos
1 Reply
MichaelGinzburg
Occasional Contributor II
Try to use Pro. Pro is 64 bit and will use 64 bit Oracle client.

Desktop is 32 bit and needs 32 bit client.