Select to view content in your preferred language

Can publish GP Service but cannot run it on ArcGIS Server 10.5.1

Jump to solution
08-07-2017 07:27 AM
New Contributor III

I have a GP tool that I had no issue running on ArcGIS Server 10.3.1, but when trying to setup the service on a 10.5.1 machine, I am running into an issue that I've been unable to resolve:

The tool runs in ArcMap fine and publishes successfully, but when I run it I get the following error:

Error 000732 Network: Dataset ______ does not exist or is not supported.

I thought that for some reason the arcgis user could not access the folder, so I gave it permissions on the entire C:\arcgisserver directory

That did not fix it, so I navigated to the copied .SDE connection file in ArcCatalog at: C:\arcgisserver\directories\arcgissystem\arcgisinput\Tool.GPServer\extracted\v101\connection.sde

I was able to connect and view the data with no issues.

So then I tried a simpler tool that just lists the feature classes in a geometric network. Same issue. I noticed in the error, though, that it is automatically stripping out the "Database.SchemaOwner" heading on the data. I manually entered these back in and the tool worked.

Going back to the first tool, I noticed the same thing. The tool is looking for this and failing:


When it is supposed to be looking for:


Why is it stripping these values out? It seems to do this on its own without me telling it to. I even went into the extracted copy of the python script and explicitly added the paths into the code, and it is still doing this at runtime anyway. Since it is doing this, it cannot find the data it is looking for and thus failing to run.

0 Kudos
1 Solution

Accepted Solutions
New Contributor III

Well, I never did figure out why this was happening, but I finally have a work-around that was successful. I wanted to share it in case anyone else runs into this issue:

  1. Do not use the built in database connections; create a .sde connection file somewhere on the server (C:\MyConnections\connection.sde) and use that to load data into the GP tool.

  2. Run the tool and publish it.

  3. After publishing, navigate to the staging folder and find the toolbox in there: 

    C:\Users\username\AppData\Local\ESRI\Desktop10.5\Staging\arcgis on server.domain.com_6080 (admin)\sddraftToolboxes\MyToolbox.tbx

  4. Copy the above toolbox, then navigate to the export folder for the service:


  5. Paste the copied toolbox from the staging folder over the same toolbox in the export folder and replace it.

  6. Restart the published GP Service so that it pulls in the change.

  7. The GP Service should now run correctly.

I am not sure why this is happening, but the above steps seem to fix it. Something is happening to the toolbox when it is published that is causing its parameter validation to fail. I was looking in the Python code for the tool until I realized that the code never actually ran; it was failing at parameter validation. Also, it did not like if I used a connection file within the systems "Database Connections" path; it wanted a .sde file sitting on the C: drive that it could easily find.

I hope this helps someone else.

View solution in original post

12 Replies
MVP Honored Contributor


This thread would get more visibility if placed in the ArcGIS for Server‌ space instead of the GeoNet Help.

From looking up that error code, I came across these two tech support articles:

Error: 000732: Dataset does not exist or is not supported 

FAQ: Why am I getting "Error 000732, does not exist or is not supported", in a script run outside th... 

New Contributor III

Hello Adrian,

Thank you or the suggestion to move the question to the correct space.

As for the tech support articles, I have read those as well and my issue seems to be unrelated to what they are describing, however I will try a few of the solutions again to make sure I didn't miss anything.

I'm still not sure what changed  between 10.3.1 and 10.5.1 that would cause this to occur, but it seems to be specific to GP services. All of my regular map/feature services work perfectly fine. I tried adding a few messages in the Python code to see if it gets to them, and it never does. It fails almost instantly, as if it's doing a parameter verification before even running the Python code, and in this verification it can't find the data it is looking for.

0 Kudos
Regular Contributor

Hi Jeremy,

Is your geodatabase which contains the network dataset versioned? You may want to check to make sure the .sde connection registered with your ArcGIS Server Site is looking at the correct version. Also, is the 64-bit version of the database client software installed on all the ArcGIS Server machines in your site?


New Contributor III

Hi Micah,

Thank you for the great suggestions.

The geodatabase only has the DEFAULT version and no others. I also verified that the 64-bit version of the database client is installed. Also, I would assume that none of the other services would work if anything was amiss here, but they are all working correctly. Only the GP services get this error.



0 Kudos
Regular Contributor

Hmmm. Which version of ArcGIS Desktop are you using to publish your GP service (or save your .sd file which you upload later)? They need to match for GP services from what I can tell.

New Contributor III

I am using ArcGIS Desktop 10.5.1 to publish the service. 

0 Kudos
Regular Contributor

Dang, I am about all out of ideas, Jeremy! Your description of the error popping up almost immediately does make it sound like a validation error. Does the tool have any complex validation logic? That might hold the key to your issue.

New Contributor III

Thanks Micah, I will check the validation logic but I don't remember it being anything too crazy. Even on the really simple tool I still had this issue.

I wonder if this is actually a bug of some sort, but there just aren't enough people using 10.5.1 yet to run into it. Either way, I appreciate your help and I will update this thread with the solution if I ever find one. 

0 Kudos
Esteemed Contributor

Do you have any other gp services (simpler setup) where you are running into this issue?  It sounds like you are working with a network dataset, which would be complex to duplicate in another environment.

Are you working on a SQL Server, Oracle or another type of geodatabase?

I do have 10.5.1 ArcGIS for Server up and running and I would like to see if I could possibly replicate your issues.