Cached basemap not fully loading in layout view

921
8
08-03-2017 08:11 AM
LeviRoberts
New Contributor III

Hello,

I have a cached map service of the County that I put in the background of most of my maps. When I use smaller maps (8.5x11) it shows up find and everything is great. But when I try to use it in bigger maps (36x48) it doesn't fully display. It loads on part of the map, but not all. Is there a setting somewhere on my service that I need to beef up? How do I make it so that the service will fully load?

 partially displayed service

0 Kudos
8 Replies
JayantaPoddar
MVP Esteemed Contributor

Assuming it happens every time for the same area,

Did you View cache completion status ? Do you see 100% completion for all the levels of tiles? You might need to add missing tiles to the cache.

LeviRoberts
New Contributor III

Hi Jayanta,

The cache is all built. I can view it just fine when I'm not in layout mode. Seems more like something to do with the amount of data I'm trying to pull from my server. A perfect example is when I'm in layout mode and I pan the map to the SE. The area that displayed properly before is still in the frame it's just in the top right portion instead of the bottom left. The portion that drew before isn't showing up, but the bottom right of the map draws correctly.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Did you check the Page and Print Setup for any anomaly? 

e.g.: Have you checked "Use Printer Paper Settings" under Map Page Size?

0 Kudos
LeviRoberts
New Contributor III

No anomaly there that I can see. Keep in mind that I can bring ESRI services in just fine and it shows everything. Just seems associated with my service. Not sure where in the service I would need to tweak this though.

0 Kudos
RandallWilliams
Esri Regular Contributor

Along those same lines, you can use a tool like Fiddler to check the web traffic. If you're missing tiles, you'll get http 404 errors. If you see those, your cache is missing some tiles at that extent.

LeviRoberts
New Contributor III

Hi Randall,

Thanks for the reply. The images are definitely cached, I can make the areas that didn't display show up just fine, I just have to pan those areas to the bottom right part of the map. It's only happening in layout mode with big maps. As of right now I have it set to 36x48 and it's bringing in just the bottom right quarter of the extent I'm viewing. Basically exactly 1/4 of the overall extent. Fiddler shows the tiles coming in fine, and never shows me any errors. 

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Levi Roberts Did you ever find a solution for this?  I just upgraded from 10.2.2 to 10.5.1, and my  raster/cached basemap is not showing on the printout, but is on the web map itself.  My services use a custom, but same spatial reference/projection for basemap and layers.

I'm still researching to make sure all else is setup, but wondering if this is a bug or other issue.  I am not getting and error on ArcGIS Server, and nothing shows up in the developer tools.  The map is created, just without the basemap.

edit:  btw - I will open another thread too, but thought I'd ask here first.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Levi Roberts   I updated my thread Solution: Print GP service not printing cached basemap (AGS 10.5.1)   with the solution to my problem.  In short, we have cached services that for a variety of reasons, the actual published mxd no longer matches the cache.  This does not cause any issues with displaying.

However, simply put, the default in 10.5.1 is to have printing go back to the mxd to recreate the basemap on-the-fly instead of  reading from the cache.  The default in 10.2.2 was to always read from the cache.

The checkbox that was causing all this confusion is in the services: 
Service Properties (Service Editor) -> Capabilities -> Mapping ->

   "Allow per request modification of layer order and symbology"

 

  • in 10.2.x this was UNCHECKED by default.
  • in 10.5.1 (unfederated) this is CHECKED by default

  • Note: Federated AGS may have it unchecked by default. This was not verified (since it was not my setup), but was the initial setup the tech was using. She was not able to reproduce the issue on that setup, but this was not retested to know for sure.

 

--> SOLUTION <--  To force the print geoprocessing service to read from the cache and not the source, make sure to uncheck the box.

for more details, check out the other thread.  This may not be the same as your issue, but might be worth a look.

0 Kudos