Bad login user while Registering Data Stores

04-24-2014 01:12 PM
New Contributor II
This isn't a question, but we're posting a resolution for an issue.

While attempting to register a map as a service in ArcServer 10.1, we kept getting the message in this post's attachment.

So, we found that our:

  • GIS Services connection worked

  • SDE Connection worked

  • PG Client Libraries were properly installed on both Server and Desktop

  • All users were set to TRUST in pg_hba.conf

Both ArcMap and ArcCatalog would continue failing to register the data with our ArcGIS Server.

To resolve this, we opened the pg_hba.conf and updated the loopback addresses from MD5 (default) to Trust. Once this was done, we were able to register the data.

I'm guessing this may resolve the issue with other flavors of SQL besides Postgres.
Tags (2)
0 Kudos
5 Replies
New Contributor III


a bad log in user error from postgres means that you were not passing in a correct password or that postgres was not setup to allow connections from your ip address, by changing the authentication method in pg_hba. conf from md5 to trust, you told postgres not to check your password. Which suggests that the bad login error was comming from passing in a wrong password.

0 Kudos
Esri Esteemed Contributor

The "trust" setting is an opportunity for a fairly comprehensive denial-of-service attack

(unintentional or otherwise) to edit or delete all your data.  I strongly suggest that you

protect your data as much as you value it, by using "md5" and a password.

- V

0 Kudos
New Contributor


  I am seeing this same error in ArcGIS 10.6.1 Enterprise using IWA login and wish to resolve this either on the IT side of the house or in the postgres side.  Please advise me on a solution pathway.


Steve Sawyer

0 Kudos
Esri Esteemed Contributor

I have no advice for working with IWA.

I suggest you ask a new question, with details of the steps you are using and the error you have received.

- V

0 Kudos
New Contributor

he ArcGIS Server service in Windows runs as a task, which has a user associated with it. Does the user that AGS is running as have access to SQL Server? When a data source is published with OS Authentication, then ArcGIS Server would be using it's OS authentication, not the authentication of the user that is publishing it. This is why the database user (arcgis_db) works, but the Windows user does not work. Share

Lucky Patcher 9Apps VidMate

0 Kudos