ArcGIS Web Adaptor unable to connect to remote server using ip url

4909
2
02-12-2014 12:47 AM
HelgiMichelsen
New Contributor
I have installed ArcGIS Web Adaptor on a DMZ server outside the domain where the ArcGis Server is located.

In the ArcGis Web Adaptor, if I put http://10.10.100.10:6080 it will register the ArcGis Servers name but is "Unable to connect to the remote server".  And when I put http://gisserver.domain.com:6080 it will say "Failed to get administrator token from the GIS server."
Any solution for this please?
Tags (2)
0 Kudos
2 Replies
RichardWatson
Regular Contributor III
I do not know about the specific errors that you are getting.

Certainly, the machine in the DMZ has to be able to resolve any machine names and be able to communicate with the back-end server using whatever ports are required.  What I suspect that that you have a network configuration/permission problem.  One way to check this is to see if the Web Adaptor works correctly if you install it inside the firewall.

There are various network utilities you can use to check this.  Here is one of them:

http://technet.microsoft.com/en-us/sysinternals/jj729731.aspx

I Googled on "arcgis server  firewall" and found the following:

http://resources.arcgis.com/en/help/main/10.1/index.html#//015400000431000000
0 Kudos
HelgiMichelsen
New Contributor
Thank you very much, but sadly I have not found a solution yet.
I have tried the Web Adaptor inside the domain and it worked. Then, in the DMZ, I tried to psping the 10.10.100.10:6080 and I got 0% loss, but when I psping giserver.domain.com:6080 I get 100% loss. The 6080 port is open, but is there other security configurations I should think about?
0 Kudos