ArcGIS Web Adaptor (IIS) and IIS Components

353
3
08-26-2018 11:20 PM
faebel
by
New Contributor

Hi everyone

I have a problem regarding the installation of ArcGIS Web Adaptor (IIS), Version 10.5.1 on Windows Server 2016. After unpacking the files (before the actual installation), the IIS requirements verification dialog box, where one can choose to enable the missing IIS components automatically, does not appear. Thus, the actual installation cannot be performed. The error message is: "Specific IIS components are required for IIS 7.0 and higher. Please see the Installation Guide for more information."

I suppose I could set the IIS components manually, but - of course - I'd prefer not to do that. Does anyone have an idea what could be wrong?

Thanks in advance. Best

0 Kudos
3 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Fabiola,

It could possibly be a permissions error.  I always run the setup.exe as an Administrator by right-clicking on setup.exe > Run As Administrator.

0 Kudos
faebel
by
New Contributor

Hi Jake, thanks for your answer. I was logged in as the administrator and it didn't work, so that was not the problem. On a different server it worked perfectly, so I'm not sure what the problem was.

Best, Fabiola

0 Kudos
RandallWilliams
Esri Regular Contributor

I'd check the windows event logs to validate what's up. My guess is some restriction on running scripts. 

0 Kudos