ArcGIS Web Adaptor (IIS) 10.8.1 Stability Patch

1575
6
Jump to solution
12-20-2020 11:23 PM
StefanUseldinger
Occasional Contributor

Hi,

I just installed the ArcGIS Web Adaptor (IIS) 10.8.1 Stability Patch to fix BUG-000136092.

The machines are hosting two Web Adaptors each (/arcgis and /portal). In the "Installed Updates" section, the update is only shown for one Web Adaptor after the installation.

How can I guarantee that the patch has also been installed for the other Adaptor?

Capture.PNG

Tags (1)
0 Kudos
2 Solutions

Accepted Solutions
PanagiotisPapadopoulos
Esri Regular Contributor

Hi, if run the Patch Finder you will see that the patch installed on the Portal's Web Adaptor

http://downloads.esri.com/Support/downloads/other_/PatchFinder.exe

PanagiotisPapadopoulos_0-1608539813599.png

 

According to the patch description I think this is the case

https://support.esri.com/en/download/7855

PanagiotisPapadopoulos_1-1608539874953.png

 

 

 

View solution in original post

DavidHoy
Esri Contributor

There was a further clarification update to the Patch download page that explains why only one Web Adaptor appears to have been patched. https://support.esri.com/en/Products/Enterprise/arcgis-web-adaptor/arcgis-web-adaptor-iis/10-8-1#dow...

Important Note: A single installation of this ArcGIS Web Adaptor (IIS) 10.8.1 Stability Patch will update all ArcGIS Web Adaptors configured on a machine; no additional installation or configuration is needed for multiple web adaptors on a machine. You will observe some limitations with the tools used for finding and notifying of patches. The PatchFinder.exe is currently limited to only showing one web adaptor even though the patch has been applied to all web adaptors. The Patch Notification tool does not currently support showing patch notifications for the ArcGIS Web Adaptor.

 

View solution in original post

6 Replies
PanagiotisPapadopoulos
Esri Regular Contributor

Hi, if run the Patch Finder you will see that the patch installed on the Portal's Web Adaptor

http://downloads.esri.com/Support/downloads/other_/PatchFinder.exe

PanagiotisPapadopoulos_0-1608539813599.png

 

According to the patch description I think this is the case

https://support.esri.com/en/download/7855

PanagiotisPapadopoulos_1-1608539874953.png

 

 

 

StefanUseldinger
Occasional Contributor

So is it installed for both Web Adaptors on the same machine? To me, it doesn't seem as if this would be the case...

 

Capture.PNG

0 Kudos
PanagiotisPapadopoulos
Esri Regular Contributor

No it is installed only for the Portal' s Web Adaptor (Instance portal, in my case).

There are 2 web adaptors configured, one foe the Portal component  and one for the GIS Server. The Patch according to the description is for the Portal component.

PanagiotisPapadopoulos_0-1608541411574.png

 

StefanUseldinger
Occasional Contributor

Thanks for the clarification!

DavidHoy
Esri Contributor

There was a further clarification update to the Patch download page that explains why only one Web Adaptor appears to have been patched. https://support.esri.com/en/Products/Enterprise/arcgis-web-adaptor/arcgis-web-adaptor-iis/10-8-1#dow...

Important Note: A single installation of this ArcGIS Web Adaptor (IIS) 10.8.1 Stability Patch will update all ArcGIS Web Adaptors configured on a machine; no additional installation or configuration is needed for multiple web adaptors on a machine. You will observe some limitations with the tools used for finding and notifying of patches. The PatchFinder.exe is currently limited to only showing one web adaptor even though the patch has been applied to all web adaptors. The Patch Notification tool does not currently support showing patch notifications for the ArcGIS Web Adaptor.

 

MargaretBaker
New Contributor II

I hope that the Patch Notification tool is being fixed to find patches for Web Adaptor if it is installed on the machine in question