ArcGIS Server publishing fails due to 0x80040111 ClassFactory error

1314
1
11-17-2016 11:13 AM
soniadickerson1
Occasional Contributor

We have ArcGIS 10.3 installed on 3 windows 2012 servers that participate in a site configuration.  Last week I installed the 10.3.1 Geocoding Maintenance patch on all three.  But now, we can't publish consistently. 

Nearly every other time, we get the Packaging succeeded, but publishing failed error, when attempting to publish a service.  Upon reviewing the GP Results, we get the following

Failed.

AutomationException: 0x80040111 - ClassFactory cannot supply requested class

Error:  the servers publishing job didn't succeed.

In the arcgis server logs, we get the following errors:

The containing process for System/Publishing Tools job 'jobname' has crashed

All three servers have the same patches installed.

ArcGIS 10.3.1 for Server
ArcGIS 10.3.1 for Server Geocoding General Maintenance Patch
ArcGIS 10.3.1 for Server Security Update 2 Patch

Esri Roads and Highways 10.3.1 for Server

Any ideas regarding solutions, would be greatly appreciated.

Thanks very much,

Sonia

0 Kudos
1 Reply
by Anonymous User
Not applicable

Hello Sonia,

There is multiple way to create/ publish map services.
Try to create SD file for this map services then upload this SD file using ArcGIs server tools or use server manager to upload this SD file.

If again its not happen then you have to use json backend process to publish service using arcgis server admin account it works 100%.

0 Kudos