ArcGIS Server Manager redirects from 6080 to 6443 after upgrade

7480
2
Jump to solution
05-05-2016 07:33 AM
ChrisKelley
New Contributor III

Hello,

I am learning on the fly until I can get some training.  I upgraded our Multi-Server Test environment from Server 10.2.2 to 10.3.1.  I configured the Web Adaptor(s) and now the ArcGIS Server Manger at servername:6080/arcgis/manager/ redirects to servername:6443/arcgis/manager/ .

I also get a certificate error now.  Our IT group has upgraded our certificates, but I believe they are only for the external addresses and not the internal addresses to the servers.  I am not a DNS, Web, server expert by any means 

I have been doing some reading, but have not had luck yet.  6443 is for https: and 6080 is for http: from my reading.  Is this new in 10.3 for 6080 to not work?  Server Administrator still works fine at port 6080.   Is there anything I actually need to be worried about since it is all inside the firewall and not available to the public.  The external site is working fine and I am not having any issues with publishing map services.

Thanks

Chris

0 Kudos
1 Solution

Accepted Solutions
ThomasEdghill
Esri Community Moderator

Hi Chris,

As of ArcGIS Server 10.3.1, ArcGIS Server Manager will redirect to HTTPS using port 6443 by design. Some information can be found in our documentation. Please see the sub-section titled "Securing your login credentials" at the following link: Log in to Manager.

If you wish to bypass using HTTPS altogether, this can be disabled from the ArcGIS Server Administrator site - once the server is set to use HTTP only, then ArcGIS Server Manager will no longer redirect to port 6443, though this comes at the cost of not leveraging HTTPS. Information on doing this is similar to the steps outlined in the following documentation: Disable HTTP access to ArcGIS Server. However, when getting to step 3 in this document, the option of "HTTP Only" would need to be chosen instead of "HTTPS Only."

You also mentioned that you were getting certificate errors. These may be caused by a warning which is sent from your web browser when the default self-signed certificate is used - ArcGIS Server creates a self-signed certificate upon site creation for each GIS Server machine that participates in the site. More information on suppressing the warnings from the default self-signed certificate can be found here: Suppressing warnings from self-signed certificates.

As a further aside, please ensure that the Web Adaptor has also been upgraded to 10.3.1 to correspond with the version of ArcGIS Server that it is working with.

I hope this helps!

View solution in original post

2 Replies
ThomasEdghill
Esri Community Moderator

Hi Chris,

As of ArcGIS Server 10.3.1, ArcGIS Server Manager will redirect to HTTPS using port 6443 by design. Some information can be found in our documentation. Please see the sub-section titled "Securing your login credentials" at the following link: Log in to Manager.

If you wish to bypass using HTTPS altogether, this can be disabled from the ArcGIS Server Administrator site - once the server is set to use HTTP only, then ArcGIS Server Manager will no longer redirect to port 6443, though this comes at the cost of not leveraging HTTPS. Information on doing this is similar to the steps outlined in the following documentation: Disable HTTP access to ArcGIS Server. However, when getting to step 3 in this document, the option of "HTTP Only" would need to be chosen instead of "HTTPS Only."

You also mentioned that you were getting certificate errors. These may be caused by a warning which is sent from your web browser when the default self-signed certificate is used - ArcGIS Server creates a self-signed certificate upon site creation for each GIS Server machine that participates in the site. More information on suppressing the warnings from the default self-signed certificate can be found here: Suppressing warnings from self-signed certificates.

As a further aside, please ensure that the Web Adaptor has also been upgraded to 10.3.1 to correspond with the version of ArcGIS Server that it is working with.

I hope this helps!

MichaelRobb
Regular Contributor II

To be honest, you are going to have difficulty with this not understanding Server aspects, web or networking or Certification etc.  You will run into a scenario where you wont have good traction to troubleshoot... that is scary if this is a production environment. 

ArcGIS Server as what has been mentioned is to be changed in ADMIN to not direct to 6443.

You get a certificate error, because you get a self signed cert when installing arcgis server.

Properly you should create a Cert Request by admin >> machine >> xxxx.xx >> sslcertificates>>selfsignedcertificates>>GenerateCSR on either the self signed installed cert or generate another cert yourself in ArcGIS Server.

Your Certificate Authority will provide a SIGNED cert at which point you'd go back to the cert you generated the CSR from and "Import Signed Certificate"  You then also would need to insert a ROOT / Intermediate Key for the machine that arcgis server is on... through the "ImportRootOrIntermediate"   once the LINKS of certs is good you will then get the green lock in the browser when using that FQDN.

On the web adaptor level.. use IIS to Request the cert as the web adaptor is simply a web app.  Hopefully you have a 'cert person' to help you with this...

0 Kudos