ArcGIS Server Linux 10.7 Installation error

03-29-2019 12:43 PM
New Contributor II


I encountered an error "Invocation of this Java Application has caused an ExceptionInInitializerError. This application will now exit. (LAX) " when trying to install ArcGIS Server Linux 10.7 on Manjaro Linux KDE. However, ArcGIS Server Linux 10.6 installation works fine. Any help will be appreciated!

                 ArcGIS Server 10.7.0 Diagnostic Tool

DIAG000: Check for installation as root                       [N/A]
DIAG001: Check for 64-bit architecture                        [PASSED]
DIAG002: Check OS version                                     [WARNING]
DIAG003: Check hostname for invalid characters                [N/A]
DIAG024: Check /etc/hosts for hostname entry                  [N/A]
DIAG004: Check installed packages                             [N/A]
DIAG005: Check system limits                                  [N/A]
DIAG008: Check HTTP port                                      [N/A]
DIAG009: Check HTTPS port                                     [N/A]
DIAG010: Check Xvfb ports                                     [N/A]

There were 0 failure(s) and 1 warning(s) found:

*** DIAG002: Unsupported Linux distribution.  Check the ArcGIS Server
System Requirements for supported Linux distributions.

Enter 'q' to quit or press enter to continue:  

Starting installation of ArcGIS Server 10.7...

Note: For information on console or silent setup UI modes, please run this script with the --help option.

Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

Invocation of this Java Application has caused an ExceptionInInitializerError. This application will now exit. (LAX)

Stack Trace:
       at sun.awt.FontConfiguration.getVersion(
       at sun.awt.FontConfiguration.readFontConfigFile(
       at sun.awt.FontConfiguration.init(
       at sun.awt.X11FontManager.createFontConfiguration(
       at sun.font.SunFontManager$
       at Method)
       at sun.font.SunFontManager.<init>(
       at sun.awt.FcFontManager.<init>(
       at sun.awt.X11FontManager.<init>(
       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
       at sun.reflect.NativeConstructorAccessorImpl.newInstance(
       at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
       at java.lang.reflect.Constructor.newInstance(
       at java.lang.Class.newInstance(
       at sun.font.FontManagerFactory$
       at Method)
       at sun.font.FontManagerFactory.getInstance(
       at sun.font.SunFontManager.getInstance(
       at sun.font.FontDesignMetrics.getMetrics(
       at sun.font.FontDesignMetrics.getMetrics(
       at sun.awt.SunToolkit.getFontMetrics(
       at Flexeraar4.ab(Unknown Source)
       at Flexeraar4.<clinit>(Unknown Source)
       at com.zerog.ia.installer.LifeCycleManager.a6(Unknown Source)
       at com.zerog.ia.installer.LifeCycleManager.a3(Unknown Source)
       at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
       at com.zerog.ia.installer.Main.main(Unknown Source)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(
       at java.lang.reflect.Method.invoke(
       at com.zerog.lax.LAX.launch(Unknown Source)
       at com.zerog.lax.LAX.main(Unknown Source)
This Application has Unexpectedly Quit: Invocation of this Java Application has caused an ExceptionInInitializerError. This application will now exit. (LAX)

0 Kudos
3 Replies
Esri Notable Contributor

That OS is not listed as a supported OS at 10.6:

Unfortunately, there's no expectation that Server, or any Enterprise product for that matter, will work on unsupported operating systems, even if it worked at prior versions.

0 Kudos
Esri Contributor

ArcGIS Server is not supported on that distribution of Linux. ArcGIS Server 10.7 system requirements—ArcGIS Enterprise system requirements | ArcGIS Enterprise 

As to why it might have worked at 10.6 but doesn't at 10.7, we did change the version of the Java instance used in the installer. It is either incompatible with, or missing some dependencies from, your Linux OS.

0 Kudos
New Contributor II

I was able to install it on Manjaro Linux using the console mode: sh Setup -m console

0 Kudos