ArcGIS License Manager service randomly fails and causes licensing errors for clients using ArcGIS Pro

290
5
08-03-2022 02:15 PM
Anish_Adhikari
Occasional Contributor

We have ArcGIS license manager installed on the same machine that has ArcGIS Enterprise Portal and clients get their ArcGIS Pro licenses through it. The license manager service randomly fails and clients get this message.

Anish_Adhikari_0-1659560636275.png

When you log into the server and look at the License Server administrator, it will say that the License Server Status as not running. When you click on the Start button, nothing happens. When you open the Services console, ArcGIS License Manager and Flexnet License Manager Service status says running. Both services are running under Local System account. We then have to restart the ArcGIS License Manager service and the Flexnet License Manager service, then the License Server adminstrator will show the stratus as running without having to click the start button. 

The problem then goes away for a few days then reappears. Both services are set to automatically restart after failure but does not seem to make any difference. The License Manager is running on a virtual machine on Windows Server 2019.

 

 

 

0 Kudos
5 Replies
MichaelVolz
Esteemed Contributor

Can you try installing the LM on a dedicated Windows Server 2019 server, independent of Portal, to see if that helps?

0 Kudos
Anish_Adhikari
Occasional Contributor

@MichaelVolz . We had a dedicated license server before moving the license manager to Portal and we had same issues with that installation as well.

0 Kudos
ZacharyHart
Regular Contributor

Are there any AV applications blocking the process somehow?

0 Kudos
Anish_Adhikari
Occasional Contributor

@ZacharyHart  no. ESRI suggested that we upgrade the license manager to the latest version and change the license file to use mac address of the server instead of vmid. They said that one of the customer was able to solve same issue using this approach. Otherwise they said we need to either use concurrent use license or move the license manager to a physical server.

 

We have implemented the suggested change from ESRI by configuring the License manager to use machine name. Fingers crossed, we will see how it goes. ESRI support mentioned that the Flex licensing services is very sensitive to even the minor changes to VM configuration.

 

Update: We have not had any issues with the license server once we changed the license file to use MAC address of the virtual machine instead of the VMID.

0 Kudos
BuffaloCoWI
New Contributor II

The other customer ESRI was referring to was probably from this other post.

I had a similar problem recently. License Manager wasn't stopping, but I had to re-read the licenses every morning or users couldn't open ArcGIS Pro that was authenticating through our portal. Creating new license files with the MAC address instead was the solution, so the licensing tools on My ESRI should warn against using the Cloud Instance ID.

0 Kudos