ArcGIS JavaScritp fails to display services published with ArcGIS Server 10.6.1,

200
2
01-03-2019 02:05 PM
JamalNUMAN
Esteemed Contributor

ArcGIS JavaScritp fails to display services published with ArcGIS Server 10.6.1,

 

I observed that, despite the fact that the service can be consumed and displayed in properly in ArcMap, ArcGIS JavaScritp fails to do so. Is this a documented issue in 10.6.1?

 

What could be the issue here?

 

Thank you

 

Jamal

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine
2 Replies
DanielCota1
Occasional Contributor

Jamal NUMAN

This can be simply a case of the service not loading promptly and it just needs a few minutes to draw (since it contains so many records), especially if the default extent is for the entire service area.

You can try zooming in/out to see if the service will draw closer extents more quickly since less features need to be rendered. The JSAPI is really minimal in terms of what it requests from the service, so unless there is something underlying with the service that is a problem, then it should not be a problem to load here.

One thing you can check too is how it displays in the ArcGIS Online map viewer. This usually zooms in the default visible extent of the service, so you may see it appear there without having to tinker with it.

-Daniel

JamalNUMAN
Esteemed Contributor

Correct. But how it can be explained that the same service has much better performance (can be displayed relatively fast) in ArcMap and Geocortex but it takes really much of time to be displayed in ArcGIS JavaScript or ArcGIS Online Map Viewer to the degree that it gives the impression that it fails

----------------------------------------
Jamal Numan
Geomolg Geoportal for Spatial Information
Ramallah, West Bank, Palestine