Select to view content in your preferred language

ArcGIS Enterprise Geodatabase Functionality Matrix?

1182
4
04-03-2023 03:30 AM
SimonSchütte_ct
Occasional Contributor III

Is there an overview of supported features by ArcGIS Enterprise Geodatabase version?
Not everyone can easily upgrade to the latest EGDB version. I need a way to check feature compatibility without testing everything myself.

Which functionality is linked to ArcMap/ArcGIS Pro/ArcGIS Enteprise or to the EGDB?

https://enterprise.arcgis.com/en/server/latest/manage-data/windows/client-geodatabase-compatibility....

Preferably there would be a compatibility matrix for each EGDB feature and its dependency to the EGDB, ArcMap/ArcGIS Pro/ArcGIS Server/Enterprise Version.

4 Replies
AyanPalit
Esri Regular Contributor

@SimonSchütte_ct Best to focus on the specifics than comprehensive compatibility matrix as there are many dependencies. Additional reference:

https://pro.arcgis.com/en/pro-app/latest/help/data/geodatabases/overview/client-geodatabase-compatib... 

 

Ayan Palit | Principal Consultant Esri
0 Kudos
SimonSchütte_ct
Occasional Contributor III

@AyanPalitThank you for the reply! The problem is, there is no mentioning of version specific feature support.

It states:

  • You want to take advantage of functionality that is available only if you use a newer release of the geodatabase. Check each version of What's new in ArcGIS Pro for information on new functionality and dataset types in the geodatabase. Be aware that when you create or upgrade certain types of datasets, such as a parcel fabric or a network dataset, older clients may not be able to access the dataset.

However, the What is New information is not a complete representation of all changes and only goes back to version 2.9


Let´s say in environment A I have a EGDB version 10.9.0.2.7 deployed. In Environment B I have a EGDB version 10.7.1.2.4. What features are not supported by the older EGDB version that are available in the newer version independent from the client?

0 Kudos
AyanPalit
Esri Regular Contributor

@SimonSchütte_ct Understood, I realize the gap. Hence, advice to focus on the specific features you are after.

Ayan Palit | Principal Consultant Esri
SimonSchütte_ct
Occasional Contributor III

Ok, I created a EGDB in version 10.9 and want to import the XML Workspace into the older EGDB. I remember getting a generic error message about unsupported data types, but nothing specific. So how do I analyze, which features are not supported by the older EGDB version? Preferably I´d like to know the incompatibility in advance.

In one case I had 1:n->1:n Relationship classes (composite, message forwarding), which is supported in EGDB v.10.9, but I don´t know, how many versions this is backward compatible.

0 Kudos