ArcGIS 10.4 server Linux installation not working

460
3
08-22-2018 01:07 PM
Highlighted
New Contributor

Hi,

I have tried to find a similar discussion on here where some one else has had the problem of the installation not installing any files in the installation directory despite having 755 set as the permission. I do get an install.dir directory created in /tmp but nothing written to /opt/arcgis Here's the output when I run the install:

[mfhssrpk@arcgis ArcGISServer]$ /home/MFHSSRPK/ArcGISServer/ArcGISServer/Setup -m silent -l yes -a /home/MFHSSRPK/ArcGISServer/ArcGISServer/licence.prvc -d /opt/arcgis
========================================================================
ArcGIS 10.4.1 for Server Diagnostic Tool

Hostname: arcgis.its.manchester.ac.uk
========================================================================

DIAG000: Check for installation as root [PASSED]
DIAG001: Check for 64-bit architecture [PASSED]
DIAG002: Check OS version [PASSED]
DIAG003: Check hostname for invalid characters [PASSED]
DIAG024: Check /etc/hosts for hostname entry [PASSED]
DIAG004: Check installed packages [PASSED]
DIAG005: Check system limits [PASSED]
DIAG006: Check OS patches [N/A]
DIAG008: Check HTTP port [PASSED]
DIAG009: Check HTTPS port [PASSED]
DIAG010: Check Xvfb ports [PASSED]

------------------------------------------------------------------------
There were 0 failure(s) and 0 warning(s) found:

[ArcGIS 10.4.1 for Server Installation Details]
UI Mode..................silent
Agreed to Esri License...yes
Authorization File......./home/MFHSSRPK/ArcGISServer/ArcGISServer/licence.prvc
Installation Directory.../opt/arcgis/server

Starting installation of ArcGIS 10.4.1 for Server...
JRE libraries are missing or not compatible....
Exiting....
...ArcGIS 10.4.1 for Server installation is complete.

You will be able to access ArcGIS Server Manager by navigating to http://arcgis.its.manchester.ac.uk:6080/arcgis/manager.

Has anyone else overcome a similar problem?

Thanks,

Richard

Reply
0 Kudos
3 Replies
Highlighted
Esri Contributor

It looks like the installer is missing some prerequisite libraries and is failing. What is the OS version? Do you have the required packages according to the system requirements? ArcGIS 10.4.x for Server system requirements—ArcGIS for Server system requirements | ArcGIS Enterpri... 

Reply
0 Kudos
Highlighted
New Contributor

Griffin,

I'm using the following set-up:

Operating System:  Scientific Linux 7.1 (Nitrogen)
CPE OS Name:  cpe:/o:redhat:enterprise_linux:7.1:GA
Kernel:  Linux 3.10.0-862.11.6.el7.x86_64

All the following are installed:

Red Hat Enterprise Linux Server 5, 6, and 7
X Windows System package group
   Group: X Window System
   Group-Id: x11
   Description: X Window System Support.
   Mandatory Packages:
   glx-utils
   mesa-dri-drivers
   plymouth-system-theme
   spice-vdagent
   xorg-x11-drivers
   xorg-x11-server-Xorg
   xorg-x11-utils
   xorg-x11-xauth
   xorg-x11-xinit
   xvattr
   Optional Packages:
   initial-setup
   initial-setup-gui
   tigervnc-server
   xorg-x11-drv-keyboard
   xorg-x11-drv-mouse
   xorg-x11-drv-openchrome

Xvfb - Package xorg-x11-server-Xvfb-1.19.5-5.el7.x86_64 already installed and latest version
fontconfig - Package fontconfig-2.10.95-10.el7.x86_64 already installed and latest version
freetype - Package freetype-2.4.11-10.el7_1.1.x86_64 already installed and latest version
libXfont - Package libXfont-1.5.2-1.el7.x86_64 already installed and latest version
mesa-libGL - Package mesa-libGL-17.2.3-8.20171019.el7.x86_64 already installed and latest version
mesa-libGLU - Package mesa-libGLU-9.0.0-4.el7.x86_64 already installed and latest version
gettext - Package gettext-0.18.2.1-4.el7.x86_64 already installed and latest version

OpenGL version string: 2.1 Mesa 17.2.3

java version "1.8.0_181"
Java(TM) SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode)

Reply
0 Kudos
Highlighted
New Contributor

It turns out the /tmp directory was set to "noexec" as a security measure for the VM which is set by IT admin.  Once that was sorted it installed with no problem.

Thanks,

Richard

Reply
0 Kudos