Add ArcGIS Server and Windows Firewall

4171
4
03-23-2016 05:19 PM
PaulHuffman
Occasional Contributor III

I have a new ArcServer 10.3.1 installation on a Windows 2012R2 server.  I went through installing a new site and added user and admin ArcGIS server connections in ArcCatalog 10.3.1 on the server itself, and was able to preview the sample map service, SampleWorldCities.  I thought I was on my way,  but when I tried Add ArcGIS Server on a client Windows 10 PC with Desktop 10.3.1 ArcCatalog on a network without a domain to add a user connection, I couldn't seem to guess at the connection url.  Tried http://servername:6080/arcgis/serviceshttp://serverIP:6080/arcgis/services, http://NSMAP.Workgroupname.local:6080/arcgis/services and a few others, like putting /rest on the end, but they all failed. But in the first two forms, they took longer to fail,  and got a message "We were unable to connect to:..... Error:Proxy server got bad address from remote server (verify the server is running).

But then I had an idea, Crap! Is this another Windows Firewall problem on the server? https://community.esri.com/thread/174271 I turned off the server's  firewall private and public profile temporarily,  and the client PC hooked up right away with http://servername:6080/arcgis/services. 

What windows firewall settings do I need to change to fix this, and where the heck is the ESRI documentation on this stuff?

0 Kudos
4 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Paul, this may be a good place to start

Server Implementation Guidance—Trust ArcGIS | ArcGIS

The first two should work.  If you are accessing the machine within your network (and you could try to ping it) I would not think it is a firewall issue.   A few quick things to check...

  • are you providing a user/pass that have access to ArcGIS Server?  
  • are you sure you have set up the security properly?
  • do you have https /ssl in place already?  if so try https://servername:6443/arcgis/services
0 Kudos
PaulHuffman
Occasional Contributor III

I don't know why the first two in your link should work. I'm not sure why you would think it is not a firewall issue.  I'm talking about the SampleWorldCities map service that appears by default after installing Server. The service seems to be using the defaults. There are no authentications set on the service,  https/ssi are not involved.  Simply adding the service in ArcCatalog as user or administrator with http://localhost:6080/arcgis works fine when I remote desktop to the server.  On a client machine, Add ArcGIS Server doesn't work for any of the urls I tried,  but it connects easily if I turn off Windows Firewall on the server temporarily.  Shouldn't I concentrate on making a firewall exception for port 6080?Already this week I had to work on the firewall to get license service through the firewall.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I was thinking that since "I" didn't have to do or request anything special from our network folks....but maybe they already had that open.  The 6080 and the 6443 worked fine after finishing my install.

One last thing to verify is that your ArcCatalog is at the same version or higher than your AGS.  After that, I'll bow out of this conversation since I don't have control over the network and port side of things in our agency anymore (did many years ago).

0 Kudos
PaulHuffman
Occasional Contributor III

Thanks for the ideas. 

I just used Action>New Rule>Port>Specified local ports>6080>Allow the Connection>Applied to all in Windows Firewall with Advanced Security on the server machine, and the Add ArcGIS Server works for a client machine. Both are running 10.3.1.  Is that too much permission?

0 Kudos