Unable to publish to Portal; The certificate authority is invalid or incorrect

3841
2
Jump to solution
08-10-2015 04:03 AM
GoranVuksic
New Contributor

Hi all!

After restaring server with Portal and ArcGIS for Server I am unable to publish to Portal.

Portal log says:

1. The certificate authority is invalid or incorrect (WinINet ERROR_INTERNET_INVALID_CA, 12045)

2. Failed to get basic item metadata for service definition upload.: Unable to download service definition.

Any ideas what might be the reason for this? Any solutions?

Tnx in adv!

0 Kudos
1 Solution

Accepted Solutions
GoranVuksic
New Contributor

Replying to myself after finding solution:

1. Restart Server and Portal (windows) services

2. Unfederate Server

3. Restart Server and Portal (windows) services

4. Federate Server

5. Restart Server and Portal (windows) services

6. Re-add hosting server

7. Restart Server and Portal (windows) services

Might skip steps 6 and 7 if hosting server is not needed.

Goran

PS: thanks Harvey @ esri support for useful tips

View solution in original post

2 Replies
GoranVuksic
New Contributor

Replying to myself after finding solution:

1. Restart Server and Portal (windows) services

2. Unfederate Server

3. Restart Server and Portal (windows) services

4. Federate Server

5. Restart Server and Portal (windows) services

6. Re-add hosting server

7. Restart Server and Portal (windows) services

Might skip steps 6 and 7 if hosting server is not needed.

Goran

PS: thanks Harvey @ esri support for useful tips

View solution in original post

TD
by
New Contributor III

Hi,

I am using ArcGIS 10.3.1 (Portal, Server, Datastore) all on the same machine.

My server used to work very well until I couldn't publish anything anymore as hosted content to Portal (I can still publish to Server).

I had the same error message in ArcGIS Server logs.

The certificate authority is invalid or incorrect (WinINet ERROR_INTERNET_INVALID_CA, 12045), URL = ...

I followed the steps described above but it did not solve my problem. Things went from bad to worse.

I now have duplicated items in my Portal content and some of my layers are not able to be accessed publicly even though they are shared to everyone.

The error related to the certificate does not show up anymore but I am still unable to publish any hosted content to Portal.

Any idea on how to fix this ?

Thanks.

0 Kudos